KDE/Plasma: "fix" screen resolution

Hi all,

on my father’s new pc, with a newly installed Leap 15.2, KDE/Plasma frequently “forgets” the last set screen resolution. Got the hint from #kde irc channel to set in kde system settings “Desktop session” - “always start with new/empty session”. Helps a little, but not always, ~ 1 out of 10 sessions starts with 640*480 instead of FullHD.

New PC, but at least 10+ years old monitor, so my idea is that maybe this monitor might “report” it’s settings/capabilities wrong. Or “forget” to report in time, so KDE uses 640480 as fallback. Usually not a big issue to re-set the resolution, but somewhat hard in 640480 mode. And, most important, my father is now 82 years old … too much for him, as a Linux newbie :slight_smile:

So my question is: Is there any way to tell KDE/Plasma and/or the underlying X server that it should/must/has to use FullHD, only FullHD and nothing but FullHD, always?


try setting this to start on boot - it only works on X11 and not on wayland

llrainey@LLR1:~> cat video.sh
# get the video name and stick it in D
D=`xrandr --verbose | head -2 | tail -1 | awk '{print $1}'`
# tell the Display program about the 1920 FHD settings
/usr/bin/xrandr --newmode "1920x1080"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync 
/usr/bin/xrandr --addmode $D 1920x1080 
# now change the display to FHD
/usr/bin/xrandr -s --mode 1920x1080
# turn off screen blank
xset -dpms s off

you will have to “chmod 755 video.sh” for it to run.

First, check what display modes are offered via KDE System Settings > Display and Monitor. It should be possible to set there. Alternatively, run ‘xrandr’ from a terminal to see available display modes reported. If expected display modes are missing, it may be possible to add as larryr already mentioned. However, there may be a driver issue to sort. The requisite info can be got using

inxi -Gxx

@deano_ferrari and @larryr. Thank you very much, SOLVED :slight_smile:

We’re getting an error for the script, and

/usr/bin/xrandr -s --mode 1920x1080

results in

usr/bin/xrandr: failed to parse '--mode' as a number


/usr/bin/xrandr -s 1920x1080

does the job, perfectly!

There’s no need in our case to add the mode before, as it’s always there - no idea why Plasma just often “forgets” the last selected mode.