KDE Plasma 5 - empty desktop after login


  • related hardware: 2 x Nvidia 9800GT
    dual-head video cards (supports 4 monitors, but only using 3)

I’m attempting (yet again) to install LEAP 42.1 on my desktop system. I’m hoping someone can help me overcome the difficulties. :slight_smile:

I currently use OpenSUSE 13.2 on my workstation and have been for approx 12 months. But I can see I’ll need to upgrade to LEAP eventually, and have been trying to do so for the last few months.

My Acer laptop runs LEAP 42.1 very well. My workstation is another story.

So, I’m trying to configure LEAP 42.1 the same way I configured 13.2 (and before that, several years of Kubuntu).

  • After installing from DVD to blank HDD, then logging in, no visible mouse cursor (but I could sometimes tell where it was via mouseover effects).

  • From within Konsole, ran a full update on system. After reboot, still no visible mouse cursor.

  • So, I ran text-based YAST from within Konsole and added the Nvidia community repo. Installed Nvidia driver (340.98). Reboot.

  • Now I have a mouse cursor, and one Xscreen (center). Left and right are disabled. No problem. Create new Xscreens for each (as I have always done) via Nvidia settings, enable Xinerama, then log-out and back in so new Nvidia config is loaded.

  • Login screen appears. Logged in, KDE/OpenSUSE desktop splash animation appears, then stalls. About 30 seconds later, screen clears and I have 3 empty black desktops. Mouse cursor visible, but no panels, no right-click action on mouse. Alt+F2 still works so I can launch things.

  • I can start an application but if I maximise it, it stretches across all 3 screens instead of just the screen it is on. In 13.2, it would only maximise to the current screen.

  • If I run Nvidia settings again and disable Xinerama, I can then log-out and back in and get at least one screen with an actual desktop to show.

  • If I log in using IceWM, all screens and desktops work.

Can someone please advise me how to get this working as it does in 13.2?

Thank you.

Hi CheapDrunk,
I know it’s over a year since you posted this without anyone replying, but did you work it out?
I’m having exactly the same problem also with two nvidia cards and i’m tearing my hair out. More frustrating is that it was working but I decided to delete my old configs and start again because something else wasn’t working properly after a distribution upgrade. I can’t even remember what that was.
Anyway if you or anyone reading this knows the solution please get back to me. My googling skills only found this thread for the same problem as i’m having.


So far I’ve worked out my problem is being caused by KWin. I can still move any window on the second display of a alt-click on them and drag them back into view on monitor one. Also if i kill KWin i can see the wall paper and any windows on my second monitor. Beyond that i’ve become frustrated and am currently installing Gnome. Which I kind of hated but if it’s going to run two monitors I’ll make friends with it.

Hi Matt,

No, it’s only been about 1 month. :wink:

I couldn’t work this out and no-one on this forum replied - so I guess no-one else has seen this, or they don’t know how to fix it. Kinda disappointed that the forum members didn’t even suggest things to try or logs to look at. Clearly, I wasted my time signing up here.

I’m still on 13.2 for my desktop system as LEAP 42.1 is unusable in this state.

I hope you have better luck than I did. :nerd:

Bad attitude dude, bad attitude. Life happens, people are busy. Maybe no one who might know was around at the time you posted. There is also the mailing lists and irc channels you could have tried, or google (the answer need not be found just here).

In any regard, I’ll address your recent thread.

and what about updating Leap 42.1 and falling in a state with a working session, programs running but just a blank desktop?
No more right click menu, no more icons, no more wallpaper, just a compact black nowhere with the widgets in the application bar…

Oooh yeah, i am really learning a lot using leap42 with KDE…
“if it works don’t fix it…”

And if someone that already was in this situation and founded a workout, will post it i will really appreciate it.
Meanwhile i’ll keep looking in Google and in this Forum…

Luckily i can almost use the system… Great Linux !

OK. I got it by myself.
a short history:
I am afraid of updates now: everytime i do one, the system break in a more or less complicated way so i rarely do it and when i do i usually have hundreds or thousands of updates. No, i don’t update every twenty years, just one month is enough.
Then i update in bunches of packets. I update Kernel and videodrivers (Nvidia) one at a time and i reboot crossing my fingers every time. This time i updated plasma alone and got a dependencies warn.

Yast complained incompatibilities with versions. It said that no one was providing “blablabla” and offered the option to not install update or to break package.
As the version not provided was the one installed (?!?), i decided to break the package and, after installing, checked for dependencies: Yast said that everything was OK so i restarted the machine and KABAM !! No more desktop…
Everything worked fine except that my desktop was disappeared.

I would really love to know how many pieces of software load to start Linux-KDE interface: until now i found Plasma, KDE, kwin, X11, QT and a bunch of related libraries…
Updating in bunches i update one component and it’s dependencies, reboot and - if everything was ok - update another. In this way i can at least know why system crashes so horribly now; which component provoked the disaster, and i can start looking for solutions.

This time the weird dependencies problem made me start a faulty reasoning: i thought that if no other dependencies where asked, there were no others. Fortunately that was not the case. Some part of software was needed but not announced; going on with update of related libraries resolved the problem.

So, is this a solution? No. I don’t even know what broke and what fixed it. But maybe someone can find useful the updating strategy i adopted with Leap 42.1 :
As i wrote “if it works don’t try to fix it”. I know that too many things don’t work as expected, but in general the system is getting better and better, so just learn to live with it. Sure, we could report bugs, but seems that KDE programmers decided to do all by themselves and rarely a bug get solved in this way, in my experience.
Finally : “if you want it, learn to do it by yourself” and be happy and grateful when someone helps you…
Hope that this world, that used so many years the KISS principle will remember it. Meanwhile we are in the state where “any sufficiently complicated technology can not be distinguished from magic”

Good luck !

So what repos you have if you have mixed versions it is certain it will break something :open_mouth:

show zypper lr -d

Thank you for your interest gogalthorp

here is the listing for my repos

| Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service

1 | KDE_Frameworks_5 | KDE Frameworks 5 | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.1/ |
2 | Qt_5 | Qt 5 | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.1/ |
3 | SoloRPM | SoloRPM | Yes | ( p) Yes | Yes | 99 | plaindir | dir:///home/pep/bin/rpm |
4 | Wolfi | Wolfi | No | ---- | No | 99 | rpm-md | http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_42.1/ |
5 | download.nvidia.com-leap | nVidia Graphics Drivers | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/leap/42.1 |
6 | ftp.gwdg.de-suse | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/ |
7 | google-earth | google-earth | Yes | ( p) Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64 |
8 | http-download.opensuse.org-0127a60c | openSUSE:Leap:42.1:Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/ |
9 | http-download.opensuse.org-12582276 | openSUSE:13.2:ports | Yes | ( p) Yes | Yes | 99 | NONE | http://download.opensuse.org/repositories/openSUSE:/13.2:/Ports/extra/ |
10 | http-download.opensuse.org-12aee491 | openSUSE:13.2 | Yes | ( p) Yes | Yes | 99 | NONE | http://download.opensuse.org/repositories/openSUSE:/13.2/ports/ |
11 | http-download.opensuse.org-1bfa12ae | devel:languages:misc | Yes | (r ) Yes | No | 99 | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/misc/openSUSE_13.2/ |
12 | http-download.opensuse.org-5321143f | openSUSE:13.2:Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/ports/update/13.2/ |
13 | http-download.opensuse.org-586a25ce | home:marec2000 | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/marec2000/openSUSE_Leap_42.1/ |
14 | http-download.opensuse.org-60eb02c3 | GNOME:Apps | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_Leap_42.1/ |
15 | http-download.opensuse.org-71e9a3a1 | home:Dman95 | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/Dman95/openSUSE_Leap_42.1/ |
16 | http-download.opensuse.org-879377a4 | home:forthy | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/forthy/SLE_11_SP1/ |
17 | http-download.opensuse.org-8ab16168 | openSUSE:13.2:Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
18 | http-download.opensuse.org-8bc2de8c | graphics | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/graphics/openSUSE_Leap_42.1/ |
19 | http-download.opensuse.org-8d678b2a | filesystems | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/filesystems/openSUSE_Leap_42.1/ |
20 | http-download.opensuse.org-8fef5c24 | Documentation:Tools | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/Documentation:/Tools/openSUSE_Leap_42.1/ |
21 | http-download.opensuse.org-bbf13b6d | KDE:Extra | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_42.1/ |
22 | http-download.opensuse.org-c30f8d0e | KDE:Applications | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_Leap_42.1/ |
23 | http-download.opensuse.org-d888dd17 | Archiving | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/Archiving/openSUSE_Leap_42.1/ |
24 | http-download.opensuse.org-f33cda4e | home:forthy:branches:devel:languages:misc | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/forthy:/branches:/devel:/languages:/misc/openSUSE_13.2/ |
25 | linuxdownload.adobe.com-linux | Adobe Flash Plugin | Yes | ( p) Yes | Yes | 99 | rpm-md | http://linuxdownload.adobe.com/linux/x86_64/ |
26 | openSUSE-42.1-0 | openSUSE-42.1-0 | Yes | (r ) Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-ATAPI_iHAP422_9 |
27 | repo-debug | openSUSE-Leap-42.1-Debug | No | ---- | No | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/ |
28 | repo-debug-non-oss | openSUSE-Leap-42.1-Debug-Non-Oss | No | ---- | No | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/ |
29 | repo-debug-update | openSUSE-Leap-42.1-Update-Debug | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/debug/update/leap/42.1/oss |
30 | repo-debug-update-non-oss | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No | ---- | No | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.1/non-oss/ |
31 | repo-non-oss | openSUSE-Leap-42.1-Non-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/ |
32 | repo-oss | openSUSE-Leap-42.1-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.1/repo/oss/ |
33 | repo-source | openSUSE-Leap-42.1-Source | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/ |
34 | repo-update | openSUSE-Leap-42.1-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/ |
35 | repo-update-non-oss | openSUSE-Leap-42.1-Update-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/ |

this keeps growing because when i need a program and i cannot find it with yast i install from software.opensuse.org and it asks for new repositories sometimes. That’s why there are also 13.2 repos in the list.

Any suggestion on how to keep a stable system killing some of the repos is welcomed. My system works, but just now i am looking to messages that appears when some of the programs, that used to work until yesterday, now crash with messages like this :
KDEInit could not launch ‘soundKonverter/’:
Could not open library ‘libkdeinit5_soundKonverter/’.
*Cannot load library libkdeinit5_soundKonverter/: (libkdeinit5_soundKonverter/: cannot open shared object file: No such file or directory)

*thanks again for any suggestion, i am a reckless newbie and even something like “change priority for this and this repo” would be very important, not to mention a form to link listings instead of copying them in the body of message
I would otherwise try it in a typical trial and error strategy, anyway :wink:

Do not use repos for other versions. mixing will break things. You are pulling package for 3 distinct version. Basically you have a mess :stuck_out_tongue:

To try and recover, at boot press e find line starting with linux or linuxefi and go to end of line (it wraps) add a space and 3 then F10 to continue boot. This will get you to a terminal log in as root run yast. This is the command line version and uses tabs arrows and space to navigate. Remove ALL non 42.1 repos. exit yast and do a zypper DUP This should hopefully get you back to a single version.

BTW you don’t need 26 either it is simply the install media and would require you to insert it when updating

As a reckless newbie i got and put in practice your suggestion to eliminate redundant repositories, before receiving your answer.

My machine is working, so i used the normal Yast in the desktop environment and unchecked the enabled and autorefresh options. I didn’t delete them, as i ate to do irreversible operations on the system.
Now Yast don’t show them anymore, i could go on with updates without the interference of other versions and I even downgraded versions from 13.2 to Leap42.1 without traumatic consequences.

Then i could read your post and now i am scratching my head about the repositories to eliminate. Should i kill also

7 | google-earth | google-earth | Yes | ( p) Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64
25 | linuxdownload.adobe.com-linux | Adobe Flash Plugin | Yes | ( p) Yes | Yes | 99 | rpm-md | http://linuxdownload.adobe.com/linux/x86_64/
16 | http-download.opensuse.org-879377a4 | home:forthy | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/forthy/SLE_11_SP1/

That actually only put one application in the system?

Should i keep only repositories like
32 | repo-oss | openSUSE-Leap-42.1-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.1/repo/oss/

or i can keep also the ones which URL mention Leap like this ?
2 | Qt_5 | Qt 5 | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.1/

And finally zypper DUP will update the whole system to Leap 42.1 ?

I am afraid of the transition to leap 42.2: it has only few months and finally 42.1 is getting more stable and is forgiving me even the mess you saw.
I would like to do the transition at the next spectacular crash; and then your suggestion

at boot press e find line starting with linux or linuxefi and go to end of line (it wraps) add a space and 3 then F10 to continue boot. This will get you to a terminal log in as root run yast. This is the command line version and uses tabs arrows and space to navigate. Remove ALL non 42.1 repos. exit yast and do a zypper DUP

will be invaluable to rebuild a working system without fighting with cryptic commands. I am going to save it in my tablet, to have it at hand the day i will be watching a blank screen once more.

Meanwhile is it an abuse of your patience to ask for the questions i got ?
I really appreciate your help

Don’t need adobe you can get flash from packman. In fact that on can get you into trouble

Googlearth is neutral but best not to have extraneous when trying to get back to a stable system just disable or leave it alone probably will not hurt

SLE should not be active if you need something from there fine but do not leave active you may pull in things that break the system

Only those with 42.1 anything else may break the system. First fix 42.1 unless you do a fresh install of 42.2 which is really the over all best thing to do when things get this seriously broken

It is not all that cryptic press e to edit
mod the kernel parameter line to boot to runlevel 3 that is terminal mode by adding a space and a 3 to the end
Ok you do have to know a little Linux but the same goes with Windows and it is harder to find the right answer. I mean edit the registry yep that’s not cryptic rotfl!

The important thing is not to mix OS versions. You had both 13.2 and 42.1 updates. With that something has to break.

Got it.
I’ll follow your advice for Flash and Google Earth. SLE is needed only for Forth language but i can install it in other ways and…

I didn’t think your instructions were cryptic. As a matter of fact i think they are the best recommendation i got for the ugly days.
Cryptic were all the things i had to write to keep alive my Leap 42.1 in his first months of life.
I never reinstalled it but at the cost of writing things never seen before and never needed in the 11-12-13 cycle of life.

But that is Linux: you only learn when things don’t work anymore or you are a geek…

I really want to thank you for the time you spent helping me. Hope to meet you once more the day (hope) away my system will start fireworks again