KDE or its application: Crash; System: Freeze

openSUSE 11.0 HDD install
. Applications (file manager, office apps, browser): Crash frequently; restart often possible.
. Session: Ends sometimes suddenly; new log in always possible.
. System: Freezes suddenly; turning power off the only way to go ahead.

openSUSE 10.2 live DVD
. slower but stable

System informations:
. AOpen: MK79G-1394 (nForce2-GT)
. AMD: Athlon XP 2600+ 1.9 (FSB266)
. Infineon: 2x 256MB DDR400 (Dual Channel)
. Hitachi: HDS 721616PLAT80 (IDE ATA133 3.5")
. Terratec: Mystify 5200 Ultra (GeForce FX AGP)

uname -srvmpio

Linux #1 SMP 2008-12-12 20:30:38 +0100 i686 athlon i386 GNU/Linux

rpm -q gcc


rpm -qf $(which kde)


KDE 3.5.x is a very stable release and you should not face with such issues.
There could be something wrong with your graphics card driver.
Does the keyboard freeze when this happens? Would you be able to do Ctrl-Alt-F1 and login to console?

It happens with KDE. Don’t worry, get the latest updates and everything will be fine. Or install XFCE - like I did. It’s just ~30 MB, half of KDE’s oxygen icon package. rotfl!

From what you describe, this looks like a memory problem. I suggest you install memtest386, it makes an entry in the bootloader menu. Run memtest completely, i wouldn’t be suprised if one of the bars is rotten.

I had the same problem and i solved it.

I belive the problem is not KDE but in the /etc/fstab file and in the yeast partitioning tool.

We all used the yeast partitioning tool, that had a default way to identify the hardisk devices by id. This is in the fstab options dialog of the partitioning tool.

Probably in your /etc/fstab file you have some rows like:
/dev/disk/by-id/scsi-SATA_XXXX_YYYY_ZZZZZ-part6 …

I belive this will cause conflicts with udev, but i am not sure o it.

In any way i solved my problem changing the default, into fstab options dialog, from device id to name id, in the radio buttons that specify the way to mount the devices in /etc/fstab.

So i got an /etc/fstab with rows like:

/dev/sda6 …

and my system work. So i hope for you.


  • to all: Thanks a lot for your regards!
  • to syampillai (post #2):

Finger salutes (Affengriffe):

  • Frozen system seems indifferent to keyboard and mouse inputs:
    | - Tried: Crtl + Alt + C / X / Z / (Double)Back / Ins / Del / Esc / F1-12 / Pause; Alt + Tab / F1-12
    | - Perhaps still to test: Crtl + Alt + L; Crtl + Alt + Shift + Del / Up / Down


  • Free drivers (standard installation): Problem already occured; on the other hand I experienced 10.2 live journeys as foolproof.
  • Proprietary NVidia drivers:
    | - G02 drivers (actually for GeForce 6+): Either system was just in a good temper or this really stabilized; but no 3D acceleration; so I uninstalled.
    | - (dedicated) G01 drivers: Deliver desired graphic power; but hardly no effect to balance; even with recommended (manual) NV-GLX activation.

dattatreya wrote:
> * to all: Thanks a lot for your regards!

what is the outcome?
did following “gianni w1” fix your problem??



  • to ram88 (post #3):


| Could not look up internet address for ###.###.#.###.local.home.
| This will prevent Xfce from operating correctly.
| It may be possible to correct the problem by adding
| to the file /etc/hosts on your system.
Anyhow the browser let’s me surf.

Trial to open [My Computer]:
| Failed to open URL “sysinfo:/”.
| The URL “sysinfo:/” is not supported.
Solution: Right click > Properties > Link: erase this URL


  • Firefox
  • Opera
    | # opera
    | Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
    | NPP_GetValue()
    | 2x this line
    | Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8
    | 6x this line
    | Speicherzugriffsfehler
    | in english: Memory access error
    | #
  • OpenOffice
    On any tried desktop (KDE, XFCE, IceWM) happen quite similar accidents; they look rather GUI independent.
  • to Knurpht (post #4):

Memtest86+ v.2.01:
| Pass complete, no errors,…
Every RAM that I received as a brand new module always passed successfully such examinations.
Only concering disk drives I can complain of damages (because worn out or wrong plugged (FDD)).

Have you checked the md5 sum ofter burning the DVD ISO?

  • to gianni_w1 (post #5):

My ‘11.0 installation’ fstab had also such ‘/dev/disk/by-id/…’ expression snakes.
Of course ‘/dev/sd…’ entries are easier to read and give the list even a better look.
So I replaced these addresses, maybe that helped; since then I noticed less freezes.
However the abrupt closing of applications or sessions persisted - has another reason.

My favourite partitioners and formaters:
. parted (console): Many units (s, B, kB, MB, GB, TB, compact, cyl, chs, %, kiB, MiB, GiB, TiB)
. GParted Live: Gparted (window), parted (console)
. SUSE YaST: Many informations, options (LVM)
. Mandriva DiskDrake: Many formats (…ntfs…)

Desktop Communication:
For access to the disc I often open applications through konsole:
| $ su
| # konqueror
| DCOPClient::attachInternal. Attach failed Could not open network socket
| …

Filesystem Tools:
Meanwhile I searched a more facile way to enter all disc areas as a user:
With the YaST Partitioner I assigned the ‘Fstab Option’ ‘Mountable by user’.
When I applied, the system hung up; because the affected root was mounted?
Could only turn off power; then something was damaged, every start-up broke;
Unfortunately the repairing routine from the DVD recognizes no LVM volumes.
So I newly partitioned and reinstalled openSUSE on ordinary logical volumes.
By the way, the source medium is the official pressed DVD from Novell.

Then I experienced that the installation programm has also some obstacles:

  • The more package groups choosen, process directly slowers until it stops.
  • Touching the upper left corner of the software selection frame: crash to ‘retro’.
  • Language > Details > Locale Settings for user root: Change only in runlevel 3!
  • Some crashes while installation throw to a DOS style menue (what’s the name).

For getting to know unix world I tend to install hardly every interesting package.
Although I only set up what YaST accepts, in the run many conflicts appear.
If I remember well, once there was an explicit option for full installation.

Input method:
The last sudden log out I associate with services like ‘scim’.
This input method seemed to change the key tabel on its own.
Maybe theire were two versions of ‘scim’ installed and active.
Because I recognized two icons on the task bar at the bottom.
And their menus looked slightly different regarding the design.
Thus I threw all ‘scim’ packages down from the machine.
Since that OpenOffice and KDE sessions work more stable.
Browsers still cash frequently; but isn’t that a bit in their nature?

I was more lucky than you.
The only thing i can do is to send you my /etc/fstab file, with this configuration i had no more system crash or freeze.


/dev/sdb5 swap swap pri=0 0 0
/dev/sdb1 / reiserfs acl,user_xattr 1 1
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto,exec 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/sdb7 /sdb7 reiserfs user,noacl 1 2
/dev/sda3 /sda3 vfat user,noauto,users,gid=users,umask=0002,utf8=true 0 0

Be carefull, with another distribution (Debian) I had some trouble with the attribute of the root partition:
/dev/sdb1 / reiserfs acl,user_xattr 1 1

that I solved replacing with something like:
/dev/sdb1 / reiserfs defaults 0 1
into /etc/fstab.

Good luck.

  • to gianni_w1 (post #14):

Many times I tried to give an update, but browsers crashed so often.

My fstab now:

/dev/sda1   /a      fat32   defaults           2
/dev/sda2   /i      ntfs    defaults           2
/dev/sda3   /u      xfs     defaults           2
/dev/sda5   /boot   ext3    acl,user_xattr   1 2
/dev/sda6   /opt    ext3    acl,user_xattr   1 2
/dev/sda7   swap    swap    defaults         0 0
/dev/sda8   /home   ext3    acl,user_xattr   1 2
/dev/sda9   /       ext3    acl,user_xattr   1 1

sda1-3 I added manually; first with the mount option ‘user’.
Because I’m unsure if ‘user’ can stand alone in this field I now have substituted with ‘defaults’.
“man mount” tells according to this option the following…
"user …] implies the options noexec, nosuid, and nodev (unlessoverridden by subsequent options, as in the optionline user,exec,dev,suid).

I had to install opensuse 11.0 on another partition in my computer. Also this newly installed distro crash/freeze, so i had on the same computer two opensuse 11.0 s.o., one of those working (fine) and another crashing/freezing.
This confirm that our common problem was a o.s. configuration problem.
I had the same problem also with gnome, so it was not a kde problem.

After some work to get the same configuration for both the o.s in my computer, i SOLVED my problem changing in /etc/fstab the line defining the root partition. The correct one was:
/dev/sdb3 / reiserfs defaults 1 1

In your case it must be:
/dev/sda9 / ext3 defaults 1 1