KDE - Libre Office Writer - add forms - convert to pdf

I’ve done searching for this information, found nothing I could use.

I’m doing a document with text, images, and tables. I want to add fillable forms. Then, convert to PDF.

If I start with a blank document, then add a table with 10 rows and two columns. Click on don’t split table. Table style none. Click on insert.

Right click on table → properties → boarders → 4 of 5 → click ok

Left column is labels. Right column is data.

Insert → text box at r2 c2 → draw as close to boarder as possible.

View – > tool bars → all 3 form check-boxes


I need a walk-through step by step how to add text boxes, change font in text boxes, change text size in text boxes, and more. ??

How to automatically align to the inside of table cell.


I made a form a few years ago. All properties were changed in “Control Properties”. Select the box you want to change and navigate to Form->Control Properties. Scroll down to font, text, alignment…etc.

I figured that out and it didn’t work. Editing the ODT file, I changed them.

Right click → properties → font – > deja vu sans 14 point → close

The right field is deja vu sands 12 point: “Data1”.

File → Export → Directly as pdf → save

Click on pdf file → click on show forms → font smaller about 10 point ??

I didn’t check all sizes and fonts but I had no problem changing fonts and sizes in my version of oowriter [1]. So it might be the version in Tumbleweed that is working, I see one thing that is not optimal and that is when I click on the pdf and fill out the form. When I fill out the form it’s a different font and size [2] but as soon as I click “show form” again it’s the correct font and size [3].

[1] Screenshot_20231114_064914

[2] Screenshot_20231114_065646

[3] Screenshot_20231114_065710

The text entry is a tiny font (10) and final font is 14. I have to switch back and forth to check the if the font fits the line.

Is there any way to change the size font of the text entry?

Click show forms

Text entry
Hello1. Hello2. Hello3. Hello4. Hello5. Hello6. Hello7. Hello8. Hello9. Hello10. Hello11.

show forms click

Hello1. Hello2. Hello3. Hello4. Hello5.

Rather, this may be an Okular problem. I checked with MasterPDFEditor 5.0 and it was the correct size. Okular are not 100% good on forms. We often get 1.7 documents with forms in them sent to us and that is more than often a problem.

So, an okular design flaw. MasterPDFEditor isn’t found on yast → software. Any other suggestions?

I’m stuck again. I can get the text boxes to export or edit font size or type. ?

Right click menu doesn’t show anything, but position and size of the text box. Use view → text box controls, etc.

I need to suspend this topic. As I have a new problem. :stuck_out_tongue:

I have it working now. Now, back to the smaller text problem.

That’s how you enlarge the small fonts :wink:

The same… this time image. I’ve done this before. The Data box 0,0 is the same font as this text box 0,1

export as pdf → save as pdf

Any other pdf viewer supported by opensuse to suggest? Firefox, no, same small font.

Tried other save as settings, same problem.