KDE Freezes randomly and only the mouse pointer works

Hi, lately during the normal use of my Samsung laptop (model Ativ Book 2 NP270E5G-X01IT) configured in dual boot with Windows 10 and OpenSUSE Leap 42.3, the KDE desktop environment randomly freezes letting me move only the mouse pointer. If I a media file is playing, i can still hear the audio but the video is frozen.
Can you help me?

Thanks in advance.

P.S. Sorry if my English can be wrong, I’m Italian.

two things come to mind

  1. what video driver do you have, google says that laptop is optimus so you;d need bumblebee (with the nvidia driver as noveau does not like plasma 5)
  2. is windows fast boot turned off, as that does not really shut down windows it can cause trouble (afaik you can no longer disable fast boot and that taints the windows partition so don’t try to access it)

1: For nvidia optimus i use bumblebee with the official nvidia drivers (I installed the nvidia-bumblebee package from the bumblebee repository), I’ve blacklisted the nouveau drivers. For the normal work I use the integrated Intel card with the kernel drivers.
2: The windows fast boot is disabled, even because I’ve got an ssd installed in my system.
It does that thing especially when i leave the laptop alone for a while or during web browsing.

P.S I can access to the TTY consoles normally.

try a new temporary user account to make sure it’s not a bad config file in your profile

am few things to consider
is your OS up to date if not do update it

zypper up

is that a clean install or an upgrade from a previous version
if it’s an upgrade (doesn’t matter of it was an offline disk or an online live upgrade check for previous installed version packages)
assuming you had 42.2 installed try (I’ve noticed both disk and online upgrades resoling with not all packages being upgraded)

rpm -qa --queryformat "%{Name}:%{Distribution}
" | grep -F "42.2"


I experience the same problem : after a few hours of work, desktop freezes and only the mouse seems to react. Any clic, anywhere does nothing. I can ctl+F1 and log in on text console and top but no process seems to overrun… The only solution is to halt system and reboot.

I first tried, as sugested in release notes, suppressed kmp package : zypper rm drm-kmp-default. But freezes still appear at random times…

I’ve read this link before falling on this thead :
It looks like the same problem on 42.2 and my computer (dell XPS 1210) is equiped with intel 945 GM !

I tried to follow the advice. First I tried to rename intel_drv.so so that “xorg manage in another way” but result is that screen start to blink at the end of the boot process and stuck there. Even failsafe mode leads to blinking screen. I had to boot on my old 13.2 to replace the intel_drv.so file in the initial way.

I tried also to force uxa acceleration but on leap 42.3, file /etc/X11/xorg.conf.d/20-intel.conf doesn’t exist… locate intel.conf returns nothing.

As the uxa seems to fix the bug on 42.2, is there a similar way on 42.3 to do the same fix ?

Thanks for any help,

that file does not exist you need to create it

kdesu kwrite /etc/X11/xorg.conf.d/20-intel.conf

and paste

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"

in it then save and reboot

Thanks a lot.
I created the file, rebooted without problem :slight_smile: and if I don’t know how to check if the change is effective (no indication of uxa on yast>hardware), I could already see that libreoffice is bugfree, as I had many screen refresh bugs on libreoffice before the change.

The kde freeze appear randomly so I’ll have to wait a few days to check if the problem is solved. I’ll keep informed.

Thanks a lot for your advice !

I’m back for some news : after 48h without bugs (which is far better than before), I had a less and less responsive display tonight and TOP indicate that process kwin_x11 was burning 98% CPU…
I tried to kill this process and had no more window management so I had to reboot.

But it seems a different bug that previous freeze of plasma.

Good night !

it could be a config issue you should try a fresh user account

I had a second time the same problem last night. As my computer is 10 years old and after little googling, desktop effects may be cpu consuming so I disabled in display config the desktop effects. Now the ctl+tab to swich between windows is more reactive and I hope kwin_x11 will not crunch my cpu any more.

If the problem stands still, I’ll try a new login. But I noticed that bug only when I work with kmail at the moment so it is not so easy to work on a second login and a different kmail directory where mails will be stored. But I’ll try if the bug is not solved.

I keep you informed ! Thanks,

I’m back after a few day to confirm that I had no bug any more after forcing “uxa” and removing desktop effects.

Thanks for your help !

I have the same problem , but I do not have a laptop, but nvidia screen card. I checked with htop and saw that baloo used 35% (8G) of my memory and sometimes uses 85% CPU time. Also dmesg also shows that the hid mouse is re-initialised every few seconds ?

5018.247959] input: PixArt Microsoft USB Optical Mouse as /devices/pci0000:00/0000:00:12.1/usb4/4-3/4-3:1.0/0003:045E:00CB.0011/input/input32
5018.248063] hid-generic 0003:045E:00CB.0011: input,hidraw2: USB HID v1.11 Mouse [PixArt Microsoft USB Optical Mouse] on usb-0000:00:12.1-3/input0
5070.261526] usb 4-3: USB disconnect, device number 16
5071.813681] usb 4-3: new low-speed USB device number 17 using ohci-pci
5071.981417] usb 4-3: New USB device found, idVendor=045e, idProduct=00cb
5071.981425] usb 4-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
5071.981426] usb 4-3: Product: Microsoft USB Optical Mouse
5071.981427] usb 4-3: Manufacturer: PixArt
5071.988667] input: PixArt Microsoft USB Optical Mouse as /devices/pci0000:00/0000:00:12.1/usb4/4-3/4-3:1.0/0003:045E:00CB.0012/input/input33

I then pkill -9 baloo and the system is running without a hitch …

This is Leap 42.3 , lastest updates AMD Quad Core 8G Ram, running krusader and qtcreator.

Any suggestions ?


you diodn’t say what video driver you use, noveau is broken on plasma 5 you need nvidia’s propitiatory driver

zypper ar -f http://http.download.nvidia.com/opensuse/leap/42.3/ nvidia
zypper ref
zypper inr

if the above doesn’t fix things start a new thread