KDE: Fonts, icons and menus too big or disproportionate


recently, I’ve installed openSUSE with KDE as window manager. However, some icons seem too large, others okay. Furthermore, the window title bar, as well as much of the fonts, the start menu, and the task bar popup menu seem disproportionately large. I have already gone through all of YaST and the system settings, but I have only been able to reduce the window control buttons to an acceptable size, while the window title bar is still too high. Also, I have already removed all of the ~./cache folder and rebooted, but to no avail. Another thing I tried was setting the font dpi, but everything still looks weird. I am a bit confused by all of this, since there were no problems at all with openSUSE and KDE on my other laptop.

Here are some screenshots to illustrate the problem:

In the following picture, you can see that the title bar of the window is still too high. Before I changed the window control buttons to “tiny”, they took up all of the height, but the font size was still as small as you can see below. This is one of the things that I mean by “disproportionate”. Furthermore, you can see that the font in the task bar is too large.


In the next picture, you can see the start menu, which takes up the whole height and has a too high icon and font size. It takes up all of the screen, which hasn’t been the case in the installation on my other laptop. Furthermore, I have tried to add the KDE repositories to zypper, and afterwards the menu had an acceptable height, but the font and icon size was still too large, effectively hiding half of the content. After I deleted the ~/.cache folder, the appearance reverted to what you can see in the picture below.


Everything similarly with the task bar popup:


Since everything looks so out of place, I am asking myself if maybe there is just one option that I overlooked to make everything look normal?

I am on a dual monitor setup powered by a Lenovo Thinkpad, which has a monitor on its own (with a higher resolution and more dpi), but it is closed and disabled in the settings. Previously, I’ve tried to use the Thinkpad’s own monitor and just one extra monitor, but I gave up on that and obtained a second external monitor of the same model instead.

Here are some more specs:

Operating System: openSUSE Tumbleweed 20190824
KDE Plasma Version: 5.16.4
KDE Frameworks Version: 5.61.0
Qt Version: 5.13.0
Kernel Version: 5.2.9-1-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 31.2 GiB of RAM

Thanks in advance,

Hi, welcome to these forums.

A couple of things:

  • Remove the KDE:/ repos, you don’t need them to solve your issue and they will probably harm more than do good. Please stick to TW’s tested packages from the distribution repos themselves. Having those repos and not dealing with them properly can seriously bork your system.
  • Use some editor with root permissions and edit /etc/sddm.conf to add this:


, then reboot the machine. Undo manual changes to font-size etc if you still see wrong proportions, or create a new user to see if things are OK for that new user.

I am with you, but only removing the repos from the list does not change anything in the installed software. A

zypper dup

must be done to replace the “wrong” packages by the correct ones.

And allow me to add something. It seems that you are not understanding the difference between system and user environment. What you see is all desktop/user related. YaST has no modules for configuring anything of KDE. The same is for rebooting after you removed ~/.cache. Simply log out and log in should be sufficient.
Just to increase your understanding of a Unix/Linux system.

Hi, thanks for the quick answers!

I have removed the KDE:/ repos and done a dup, added the two lines to /etc/sddm.conf (which was otherwise empty) and rebooted the computer. The problem still persists. When I create a new user, there are even more problems, like a wrong order of monitors, a wrongly enabled laptop monitor, and really weird behaviour when trying to select anything on the console (e.g. letters from the first column appear in the selection when selecting some columns afterwards, or a cursor that is more than double the size of the font).

As for logging out and logging in again: I’ve actually tried that, and openSUSE just shows the same screen as when shutting the computer off, which hangs for a couple of minutes, until I lose patience and just force shutdown by holding the power button. But that’s for another thread, I guess.

EDIT: To clarify, the screen that openSUSE shows when shutting down the computer or logging off before the force shutdown is dmesg with the content of some CPU registers, it seems.

EDIT 2 (new post, as it seems I cannot edit my previous post anymore): It seems that I have overlooked it, but the symbols in the task bar, task bar pop up and start menu are good now. However, the window title bar height as well as the font size and menu size (start menu and task bar pop up) still is too big.

Solved it, but I’m not entirely sure what was the cause.

While trying to solve another problem, I added the parameter “nomodeset” to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, rebooted the computer, removed the parameter again, and then force shut down the computer. After booting into the system the next time, everything is looking fine, just as it should. I hope it stays like this and doesn’t revert back on the next reboot. Thanks again.

Sorry for the quadruple post, but I just wanted to add that what I wrote in the last post could not be reproduced. Restarting the system, everything is back to what you can see in the original post’s screenshot. Trying to reproduce what I wrote did not work.

Maybe I should add that there was an update in between, which updated mesa-dri-nouveau. Despite the warning that it doesn’t work well together with KDE, I have installed it, because installing the proprietary drivers always prompted me to de-activate the current drivers (which I haven’t been able to), and another post in the forums said it’s okay, as it’s not used by the system anyway.

Nomodeset is a troubleshooting option often required to successfully install, which usually causes trouble if it remains active post-installation.

Posting back here output from:

xrdb -query | grep dpi
inxi -GxxSaz

run in Konsole could be instructive. You may need to install inxi (first). If you wish the latest version rather than an antique, you’ll need to download it from its author’s site instead of openSUSE repos. It’s simply an information collection and display script.

Thanks for the reply, but I’ve since switched to Arch. It has been a hassle to set up, but KDE worked out of the box without any major problems, although I am still tweaking a few things.

I think I’m facing the same issue with Leap 15.2. As you can see, the icons are too large, same with the titlebar. Firefox text has the correct size for my resolution, which is 3840x2160


Any idea what could be done to fix it?

I use 3840x2160 KDE and a window popped up telling me to use zoom instead of editing font size. I think there is a way to reset all the font sizes to default, then in the section Display COnfiguration there is a zoom setting which I use 150% and it works fine.

Initially I didn’t change any font size, the screenshot was taken after a fresh install. Further, I don’t want to use screen scaling. All this was working on the same notebook with Leap 15.0 installed. Now after installing Leap 15.2 (tried installing twice), this is broken. I was able to mitigate this issue now setting “Force Font DPI: 96” under the Fonts settings, but this looks like just masking an issue.