KDE Desktop gradually slows

Week-old install, openSUSE 13.1 with updates, KDE4.11.5, on a laptop with quad-core AMD with integrated “discrete class” Radeon graphics, 4 gig RAM.

Fresh boot, it’s fine, but gradually the response of KDE slows down. Apps do not slow, open browser for instance is fine. Heck, even a heavyweight app like VirtualBox is fine. Animation if I close an app is snappy, and it makes no difference if desktop effects are disabled. System monitor plasmoid shows plenty (say 50%) of RAM and CPU available. Process seems independent of load; problem happened tonight under no load at all: Booted, dined, returned to find computer unusable.

When I say KDE is slow, I mean that if I move the mouse down to the bottom of the screen, the taskbar takes minutes to unhide. Then when I click on the menu launcher, it takes minutes to open, though it may show an outline for half of that time. Then when I click on Leave, more minutes, then when I click on Restart, more minutes 'til the confirminator pops up, then when I click on that, more minutes. Yes, 15min to shut down. Right-click menu takes just as long to respond. Key bindings take forever, too.

If it were always slow, I might suspect graphics driver issues. If it slowed more when I used more apps, I’d suspect memory management issues, but getting slower over time even under minimal load, has me confused. Typical usage case is browser-based research pertaining to my new install, just some google searches and reading forum posts, and then when I go to implement whatever I read about, I can’t get the menu to open!

My research on this problem points to a lot of folks complaining about slow KDE, in older versions a few years ago (when it was working fine for me on an older computer, also with Radeon), and people telling them not to use any cool features of KDE if they want it to be faster, but not so much on the fast-at-first-but-gradually-slowing issue. Is anyone here familiar with it?



PS: I have 64bit version, and I have BTRFS instead of Ext4 - a mistake, though on old computer (with 32bit openSUSE 12.1), I installed it to try, and had only one problem, nothing like this one. (The problem I had was that it occasionally showed up missing and caused hang on boot, until I booted from CD, mounted the BTRFS volume, then rebooted from hard drive.) -GEF

http://en.opensuse.org/HCL:AMD_video_cards says opensource drivers don’t work so well on 7000-series radeons. So I installed the proprietary driver. I can’t tell a difference, and it certainly didn’t fix the problem.

I’d install the system load monitor widget, and/or use CTRL+ESC to see if some process is hogging the CPU. Alternatively you can use top from a terminal or, if your disk is trashing, iotop (this one has to be installed from yast and run as root).

I’d also try disabling the desktop effects settings in KDE system-settings. Last time I checked it didn’t didn’t play very well with the opensource drivers, and even after installing prop drivers you may have inherited the weaker effects settings. Check the advanced tab, you should set compositing to openGL 3.1 and Qt system to raster, I think.

Thanks Bruno. Yes, I do use system monitor widget and ctrl-esc; that’s how I know that even as the problem is occurring, resources are under light-to-moderate load. I haven’t done anything yet that’s required virtual ram, and cpu is next to idle while I’m experiencing the problem. Yes, I’ve tried without desktop effects, no difference. After installing fglrx, I set kwin to OpenGL 3.1, can’t tell a difference. After 45min booted, the system is draggy to the point of unuseableness, even if it’s been sitting there running nothing but a screensaver the whole time!

Created a new account (with default settings), played around in it for an hour and a half, surfing, fiddling with widgets, installing some software, editing a document, first hour without desktop effects active. It worked fine, snappy the whole time. So, something in my account is the problem. Here are the differences:

Blew out my home folders, replaced with symlinks to equivalents on windows (NTFS) partition - Documents, Music, Pictures. And those folders have everything I recovered from hard drive of old computer. Could Nepomuk be my problem?

Have a bit fancier desktop: 4 virtuals, clean but for separate wallpapers, autohide panel, independent widget set on the dashboard with 6 widgets (though I had the problem before I set up the dashboard).

I use veromix to choose output, onboard speaker or this nifty usb gizmo that has way better than laptop sound. Come to think of it, I don’t recall having the problem before I installed veromix. Otherwise, nothing on the panel that’s not default, except launcher icons.


Using NTFS for standard Linux home folders could be the problem in general. Nepomuk most likely could be having hart burn. I’d recommend turning it off. I’d also unless I absolutely had to refrain from using NTFS for any of my normal linux defined directories. It is like trying to use Ford parts on a GM car

Thanks, gogalthorpe. I just unmounted the NTFS partition, so we’ll see in an hour if it makes a difference. If so, I’ll create a FAT partition for the documents I need to access from both linux and windows, but I’m skeptical, because I had the same arrangement on the laptop I just replaced, running openSUSE 11.4.

Veromix was a bust - looks like it’s hung computers in the past but those threads are years old, and I removed veromix for a long session last night with no improvement.

I thought my new box should easily have enough resources for desktop effects, but every discussion about slow KDE says to disable 'em. So I did. Booted without desktop effects and went to bed. This morning, computer was frozen, though it had no activity since boot.

Really hoping NTFS dismount cures this.


OKay, been running for an hour since last post, no NTFS mounted, problem is back. So that’s not it. Guess I have to blow out my config file and start over a step at a time.


ok you seeing disk activity?? Did you run top to see what may be eating CPU?? Any particular program running like maybe FireFox (known memory hog). CHeck to make sure that you have swap defined and actually using it. Again top will tell

It was Veromix, afterall. Removing the widget from desktop made no difference; had to uninstall it.

My experience with linux, mainly openSUSE, for a decade now is that I really like it, use it exclusively for months at a time, but then it breaks in a way that’ll take a fair chunk of free time (and gracious help from you all) to fix. I’m blessed with a full life, but that means I don’t always anticipate a “fair chunk of free time” anytime soon, and that’s why I have to dual boot. At least for the moment, I’ve got a new install fully configured to my taste, so I’m in the “really like it” phase. Thanks again for the advice, gogalthorpe. At least I always learn a lot from these frustrating experiences.


Odd I have no problems with veromix and I run the machine 24/7 you can still use paucontrol it is just not as handy