KDE autohiding panel unhides every time a new window gets focus

Hello everybody, I am trying OpenSUSE Tumbleweed for the first time… and of course I get my list of issues.

One is this: I use KDE (5) and I set the KDE panel to automatically hide.
Well, every time a window gets focus, the panel unhides and stays there, until I move the mouse over it and away.
More noticeably, this happens when switching application (<Alt>+<Tab>), when I ask for a dialogue window (File | Open), when I close a dialogue window.
Sometimes even when I just intensely stare at the monitor (I suppose it’s really about focussing).

A different installation (and distribution) has a more reasonable policy, and pops out only when an application opens a new dialogue window, or when I poke the panel with the mouse.
I suppose this can be tuned with some KDE system setting… but I can’t figure out where. Help please?

I’m not seeing this.

I just tested with snapshot 20181015.

Does it possibly have to do with video drivers – are you using “nvidia” graphics or similar?

Thank you for the answer…

I believe the video drivers are Intel i915.

That’s what I am using. And I am not seeing the problem.

I’m not sure where else to look.

I’ve tried changing Task Manager Settings, but I have not been able to reproduce the problem.

I do sometimes see the panel unhide when there is a notification somewhere. Could that be involved?

Following your hint, I just went though all the notification settings in the corresponding KDE system settings panel. No luck.
I thought there would be some event “marking taskbar entry”, which there were actually only an handful, all very sensible, and deactivating them did not affect the issue.
It was a promising idea, though.

I’ll try some more thinking. But it’s a puzzle at present.

Is there an “Always on top” setting?
That can over-ride auto-hide, particularly if a window is slid down past the edge where your panel is.


To fix the issue of the panel unhiding every time you switch apps/windows go to Settings/Window Management/Window Behavior/Advanced and enable “Hide utility window for inactive applications”.

If you right-click the panel and choose edit, you get a number of buttons above it, the rightmost one being more options. Try this if you didn’t already.