KDE and nVidia desktop scrolling

I’m back on Windows for the moment, but I installed openSUSE 11.1 KDE earlier and all went extremely well. I installed the nVidia drivers for my 7600GT, except it messed up a bit.

The panel was a bit “corrupted” - for example, a faint and huge power button appeared behind the proper one. Also the various widgets were randomly overlapping as well.

As well as that, the desktop developed a black or grey (varied) gap below the bottom panel, and the desktop would scroll up and down when I moved my mouse to the top or bottom edge.

Remembering from use of other distributions that the “96” nVidia fixed such graphical issues, I tried to change to that, but now I’m stuck in the console/shell when booting.

Guess I have two questions:

  1. Is there an easy way to remove nVidia and get the system booted, from the console? I followed a few instructions from these forums, but they didn’t work. If not I don’t mind reinstalling it.
  2. Is there a known fix, or different driver that I can try so I don’t have the graphical issues, once I actually get it booting again.

Thanks :slight_smile:

log in as SU from the command line
$ SU
$ Yast
search for nvidia and uninstall the drivers. Should get you back to basic driver support.
I am having an issue as well with nvidia support in openSUSE 11.1.

Hope this helps?

Yes, that worked nicely. :slight_smile:

Just to find a solution to the actual drivers now.

Okay the corrupted widgets can be fixed really easily by removing and re-adding them to the panel.

The screen scrolling is due to the resolution being set at a higher resolution than your screen can handle. Use sax2 -r to reset everything and reconfigure. Make sure you get the aspect ratio and everything correct.

The 96 series are for legacy video cards I think. You should be installing the 177 or 180 series. However, the 177 series are really slow especially with KDE. You really want to try the new beta 180 driver. http://www.laptopvideo2go.com/nvidia/180series/18011_linux.exe

You have to extract the install file from the .exe (don’t worry it is a linux installer, just packaged in a 7-zip .exe self-executable). Download the p7zip tools in Yast and use the command “7z e 18011_linux.exe” to extract the install file. Afterwards run the installer.

Even though all the display resolutions, aspect ratios, etc were fine, doing sax2 -r fixed it.

I thought the slowness was 8 and 9 series cards only (7600GT here)? Although I’ll try the Beta drivers if it does seem slow.

I downloaded it by right clicking and “save as.” Then did as you said, except p7zip says “Can not open file as archive” when I try to extract it.

Permission issues? What’s the command you’re using to extract?

EDIT: DOPE, I know what’s going on. The link I gave you didn’t have a correct referrer. I gave you a direct link, so it redirects you to an HTML page saying “How did you get here?”. Here’s the correct link: http://www.laptopvideo2go.com/forum/index.php?showtopic=22301
Click the Driver link to download.

I noticed there’s a bit of screen corruption during login and logout with these drivers, but they clear out once everything is loaded. However, they’re definitely faster than the old drivers so the tradeoff is worth it.

Unpackaged it now. :slight_smile:

How do I get it to install? Clicking it opens it in Kwrite lol! and just typing it into the terminal says “bash: <filename> command not found.”

I’m still a bit of a Linux newbie in some areas - learning the commands, methods and so on.

Yeah, you should run them in the command line with “sh NVIDIA-Linux-x86-180.11.02-pkg1.run”. You can also use a wildcard so you don’t have to type it all out: “sh NV*”.

You can’t run executable files (.run,.bin,.sh) without a “./” or “sh” in front of them if they’re not part of your PATH. Using “./” is a bit more finicky because it sometimes requires you to change the executable permissions on the file.

Managed to get the drivers installed, although I had to keep switching to yast to find kernel compiling packages.

Desktop effects are disabled though, despite the drivers apparently being correctly installed. This supposed to be the case?

Accessing SaX2 through YaST, the “Activate 3D Acceleration” box at the bottom is ticked (but greyed out) with the 180.11 drivers, yet 3D effects still can’t be enabled. Going to try some of the solutions here for now. Any other ideas?

Ok, this is odd. I just reinstalled the 180.11 drivers, ran sax2 -r from the console (just after installing the drivers, no xserver running) and then started x (startx). At this point it booted me into the root account as I forgot to logout before doing startx.

The effects were all enabled, except the screen length was wrong again (despite correct settings). Re-ran sax2 -r to fix that and the effects disabled themselves and can’t be enabled again.

So any ideas on how to make it permanent?

Think I’ve got it fixed. :smiley:

Tried a different variation on the modifiers: sax2 -r -m 0=nvidia

Can anyone explain the difference to me (other than it apparently works)?

Congratulations! Sorry for the late reply.

Sax2 disables the Composite extension by default, at least for me it does. This is why you could not enable desktop effects. There’s an option in the Extensions section of xorg.conf called “Composite” and it defaults to off. Simply delete it, and desktop effects should be enabled. But your way works as well, I guess. The nvidia tag just switches to the nvidia driver, I dunno why it fixes your problem. Perhaps it loads some kind of settings profile?

I think it does. Doing it in the full console mode, it displays “options”. Without the additional -m bit, it says “NoComposite”, while with it, it says “Composite”. Maybe it is simply because it’s picking up that a 3D driver is there.

Anyway, thanks for all your help. :slight_smile: