KDE - Add forms to a table in an libre office writer odt - convert to PDF with forms - Basics

I was able to get this to work earlier., now I can’t recall how I did it. I found lots of web articles. None help.

Insert – > table → columns 2 - rows 10 → check don’t split table over pages → table style none

table 0,1: add line

View Toolbars → check form controls

Insert → text box table 0,1 → set box inside close to boarders

save as → export as pdf → save ‘test_text_box.pdf’ → select all -->save

PDF loads no forms. ??

In writer, right click no longer shows any form controls. I can’t find any method to change the font size or font type. ??

Well, had some problem setting the distance of bullet to the first letter after it. I find, help in the pop up usually can help what to do.

There are no bullets in this set of instructions. ?

Also, Libre office was updated. So, i’m testing again.

Nope, same effect the menus that allow changing font and text size disappeared.

Hi, I am just setting the bullet as example when finding some solution in libreoffice help.
I am using the latest tumbleweed snapshot so I am assuming libreoffice here is the latest also.
If you set the table to none then it will not print or show the table when you export it unless there is really a magic button hiding to make the table visible. That’s why it’s called “none” I guess. I tried what you did and it really not showing when exported to PDF. If I use the default and the other choices it will show when exported.

Form control is there to edit the font. You can do this by double clicking the left mouse or right clicking the mouse inside the text box and check control properties then navigate to the fonts and you can edit the font type and font size.

Double clicking the left mouse button will take you to the properties: text box where you can find the font editing.
Mouse right click has more options but the choice is to check the control properties to take you to the
properties: text box

Set it to default. The table exported. The text box didn’t export.

Form control side bar shows. Right click and double click does nothing. It worked before, not this time.


You need to click the design mode before right clicking the text box

double clicking the left mouse takes you directly to the above and you can click the font to modify

This is the exported pdf

This part I’ve done before. Where is the design mode button? The pencil icon is highlighted. If this is it, does nothing.

Design mode does nothing. It’s form navigator. Add new forms → make name → right click.
It’s has something to with putting a label on the text box first. :stuck_out_tongue:

Design mode does nothing. It’s form navigator. Add new forms → make name → right click.
It’s has something to with putting a label on the text box first. :stuck_out_tongue:

The right-click properties. Ivwas using before. They don’t appear.

form proprieties
control properties

Using the menus (top of page) doesn’t work. Insert → text box

Insert table 2x10 → don’t split tables → style done—> insert → right click → table proprieties → boarders → number 4 → ok

Form controls tool bar → click design → click text box → draw text box → right-click text box
control properties.

This is some design bug in libre office menus. :stuck_out_tongue:

Design on → edit forms Design mode off → edit document

Save as PDF… works, finally! :slight_smile:

sort of, back to the smaller font problem in other topic.

Thanks to those who assisted. With your help, I was able to figure out the method that works and found a possible bug in libree office writer.

It’s not a bug because it works. The clicking sequence is cumbersome. :confused:

If this isn’t a bug, then my method is simpler to understand. Based 3 days of trying to get it to work. :wink: