KDE 4 Screen refresh problems

Greetings All,

Since being forced to migrate from KDE 3.5 to version 4, I have been experiencing
problems with the way that various application’s screens get refreshed. I first noticed this effect while using X3270. If another window is moved over an active
X3270 screen, the text in the terminal window is not being completely redrawn. When moving windows around on the desktop, I will get rectangular “holes” that show the background instead of the window. Lastly, scrolling a web page in Firefox will result in garbled text, mostly toward the bottom of the page. Eventually, these “effects” clear, either by moving windows around some more, or just waiting a minute or two for things to refresh.

My first thought was this might be a problem exclusive to the current KDE level, or SUSE distro. I recently upgraded to SUSE 11.3, and discovered that 11.3 has the same issues.
Figuring that it MIGHT be a deficiency of my video card, I installed a different one
(went from ATI video to an NVIDIA card). However, the change in hardware made
no difference.

If I use Gnome instead of KDE, these problems do not manifest.

Is this a known problem? Is there some setting somewhere that I can change that may improve this? Should I start getting used to Gnome and give up on KDE?

Thanx in advance


So when you switched to using the nVidia video card, did you load their proprietary binary video driver? This is what I use and my video works great! Here is some reading for you to look at:

You should look at this document before proceeding on…

SDB:Configuring graphics cards - openSUSE

Then, take a look at the procedure I use to install the nVidia driver as I install openSUSE 11.3:

  1. During the install, when you have the option to change your booting setup, I add nomodeset to the kernel load command for the normal load/start of openSUSE. This kernel startup option is already present for the Failsafe selection for openSUSE.
  2. During the first start of openSUSE, I download the latest nVidia Video driver to the downloads folder.
  3. I change/save the System/Kernel option NO_KMS_IN_INITRD from “No” to “Yes” in the /etc/sysconfig Editor in Yast.
  4. I do an update of openSUSE on the first run of openSUSE and then a restart/reboot.
  5. In grub OS selection I add the command line option “3” to the openSUSE start line so that I just go to the run level three terminal prompt.
  6. I login in as root and change to the /home/user/Downloads folder.
  7. I run/install the NVIDIA video driver using “sh ./NVIDIA-Linux-x86_64-256.44.run” and answer all questions as appropriate for my system.
  8. Type in reboot at terminal prompt to restart the system with new video driver.

Thank You,

What James said

and how did you upgrade?
If you create a new user account and use that does it still have the problem?

Ok, here is what was tried:

  1. SUSE clean install (no saved values from 11.2)
  2. Proprietary NVidia drivers using YAST & NVIDIA repository.
    added NOMODESET to kernel load command.
    NO_KMS_IN_INITRD was already set to YES
    The proprietary drivers did not seem to make any difference for this problem. In addition, they caused
    a lot of new problems (CPU usage spiking, mouse freezes, some apps running too slow).

As I said, the problem does NOT appear when using Gnome, only with KDE. This would seem to me
that it is NOT a driver issue. Since I had exactly the same issues with a different chipset video, that
also would seem to indicate that the driver is not to blame…

In spite of the pain that KDE has inflicted, I am much more comfortable using it than Gnome. However, this
display issue may be what pushes me over…

I should also add that I am using the 32 bit SUSE.
There are a few apps that I require that do not yet work with the 64 bit kernel (maybe someday…)


I have also experienced the same problems. mostly when using firefox (and some other gtk apps).
Perhaps it is a cross desktop (gtk vs kwin) issue. With native kde applications i don’t have this glitches

I was able to fix the issue on my system by doing the following:

  1. Make sure I have the proprietary nvidia driver installed.
  2. CNTL ALT F2 and login as root. Then do an init 3
  3. Run the following command as root: nvidia-xconfig
  4. The nvidia-xconfig command will create an xorg.conf file.
  5. Edit the “Device” section in the xorg.conf file and add the following line: Option “UseCompositeWrapper” “True”
  6. Restart and it should be working. I also pasted an example of my “Device” section.

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
Option “UseCompositeWrapper” “True”