KDE 4 doesn't center images

Hello all,

I wonder whether I’m alone in having this problem : when I change the image used as background for the desktop, I would like this to display at its resolution (800 x 600), leaving the rest of the desktop free with whatever colour one has set as background colour.
This worked fine in KDE 3.x, but in the latest version of KDE (4.1.x) under OpenSuse 11.1, this doesn’t seem to work - even if you set the image to “centered”, it still gets blown up to fill most of the desktop.

Does anybody know a way around this?



Do you also have cropped selected for the image?

Thanks for your reply.

I’m not at the machine right now, will check later & reply.

OK, I’ve checked now.

The “wallpaper” in the “Desktop settings” window allows you to select a “type”. This is set to “image”.
I set the “Picture” to whatever I want my picture to be.

The “positioning” is set to centered. There is no way to select “centered+croppoed”. You can only select “scaled and cropped” (enlarges the picture to fill the entire desktop), scaled (pretty much the same, but picture is squashed instead of cropped), “maxpect” (which lets me see some borders around the picture), “centered” (with more border, but the picture is still enlarged) and some other options, not relevant here.

I notice that under KDE3.5, I display this picture from a .bmp file, under KDE 4 I had to convert that to a .png file (and yes, I checked, it still is the same size, it didn’t get enlarged whilst format-changed).



So, am I really alone in having this problem?

(I have it on 2 separate machines).


You are not alone … me too with the same problem.

Also for this problem im trying to use the effects of kde4 in kde3.
Changing the session managers>windows manager in kde3 with kde4 i can use the effects but impossible change the background also manually.
(kde4) how to set/get wallpaper using qdbus - Styles, Icons, Themes, Addons - KDE-Forum.org](http://www.kde-forum.org/artikel/18722/kde4-how-to-set-get-wallpaper-using-qdbus.html)
Black screen with lots of effect. In true lots of things dont work. I think that for the moment I still will use kde3.

I’m having a similar problem but in my case its because I’m a bonehead! When I first installed 11.0 I set my background to a pleasing color and then set the wallpaper to “slide show”. This displayed the photos at their size everything was PERFECT…until I kept messing with it. Somewhere I enabled a ‘resize’ option and now all pictures fill the entire screen, which distorts a lot of them. Now I can’t find that option to change it back.

I’m still happy as hell, I got my sierra 881 aircard up on the net in a matter of minutes (thanks to some posts on this site) and its stable and works great which will allow me to finally cut the last tether I have to Windows and give my whole hard drive to Linux!

As a workaround you could create an image in the gimp at the resolution of your monitor and then paste the image you want as a wallpaper in the center, save it… and then use that one.

Takes same more work, but the result is the same.

OK, thanks for the workaround.
Does loading such a large image slow down the computer?


The problem has gone away with KDE4.2, centering is done correctly now…
Thanks to all who responded.