KDE 4.4 RC2 Great

Running kde 4.4 rc2

python plasmoids DO work this time

No things that dont work so far

Only the cashew right top corner is back as in rc1
I prefer just a plain desktop without all the plasma *****

Installed from download.opensuse.org

Thanks for the nudge on this. We all been w8in’ ages;)

At this moment i am downloading the first update for
KDE4.4 rc2

Did not expect an update that quick

Have to agree 4.4 RC2 is nice and snappy .
Where is “show Icons on desktop” at , can’t seem to locate that feature in openSUSE/KDE4.4 .

what cant locate folder view in your desktop options?

no problems here either

It’s going well for me too.

  1. YAST link does not work from system settings. This started when I upgraded from BETA to RC1. No big deal because you can run YAST manually.
  2. Switch to the Search and Launch desktop activity you can not switch back. Add a new activity and switch this to the Desktop Search and launch, you can not remove it.
  3. Date and Time link in system settings crashes control panel.
  4. When panel is moved to the top of the screen the ‘sliding’ transition is screwy, slide-in is fine but slide-out leaves part of the applet in focus on the screen after the transition is complete (These disappear when focus is manually switched to a new applet or window).
  5. Dolphin Nepomuk search does not work (Possibly why the it’s hidden away by default).
  6. Power-Devil CPU profiles do not exist. ‘Supported CPU policies: No methods found’

These are just think I have noticed through RC1 and RC2. Despite deleting the ~.kde4 folder to start over with default settings. I realise some of these might just be version compatibility issues.

Hopefully all fixed by the final stable release.

I can confirm all your points (well, except number 2 since I haven’t tried it) but as for #6: are you sure that’s the fault of power-devil and not HAL and/or your hardware? Did it work in 4.3.x?

PD certainly can find CPU policies on my setup.

I am on OpenSUSE 11.2 (x64)

Power-Devil worked fine when running the stable (KDE SC 4.3.3) it must have broken when i switched to KDE:FACTORY

The ‘Power Management’ system settings applet does not report any issues, however changing settings here have not effect either.

Hal appears to be running however;

When trying to run solid-powermanagment on cln I get.

solid-powermanagement(10056)/kdecore (KSycoca): Trying to open ksycoca from  "/var/tmp/kdecache-row/ksycoca4"
solid-powermanagement(10056)/kdecore (KLibrary): Expected a KPluginFactory, got a KAuth::Polkit1Backend
solid-powermanagement(10056)/kdecore (KLibrary): The library "/usr/lib64/kde4/solid_hal_power.so" does not offer a KDE 4 compatible factory.

Anyone else?

  1. Yes that’s true but maybe it’s openSUSE’s fault not KDE.
  2. Never tried it
  3. There are bug reports about this and should be fixed soon.
  4. I have this annoying thing for so long that i almost don’t see it anymore.
  5. I’ve disabled Nepomuk search. I don’t use it and it always whines about something on startup.
  6. Also never tried it. But it seem that HAL daemon and KDE are not compatible ( The library “/usr/lib64/kde4/solid_hal_power.so” does not offer a KDE 4 compatible factory.) Maybe you should wait for and update of HAL.

On Sunday 24 Jan 2010 16:46, susegebr scribbled:

> No things that dont work so far

Kontact crashes for more reasons than in 4.3 but this is a known bug.

What’s just irritated me is that some bright spark seems to have thought it
a good idea in Kontact to swap the “suspend” and “dismiss” buttons round in
the task/event reminder window! That’s going to take some getting used to.

Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
“I wear the cheese. It does not wear me.”

Now why would one open systemsettings just to launch Yast? :silly:
Simply create a shortcut on the panel for it:
kdesu /sbin/yast2

I have my panel at the top, and it works fine.
After converting from 4.3.4 to 4.4. RC1 though (with panel at the top), I found it was behaving strangely. I had to delete it and create it anew from scratch to get it to work properly.

Power policies for my Cpu (Phenom II X4) are just working fine, RC1 and RC2 alike.