KDE 4.2 from factory + Nvidia 180.22: snappy!


I just wanted to mention that performance has improved very much with
KDE 4.2 from factory repo, in combination with the Nvidia 180.22 driver.
Installation of both from the repos was flawlessly, on opensuse 11.1.

KDE 4.2 looks great, and the performance really is a breeze now. I
haven’t encountered any serious bug until now after working with it for
a half day.

Have to agree here working really well with rc1 and the new nvidia drivers


Gkrellm has now transparency with plasma in kde 4.2 rc1

KDE 4.2 is flying with nVidia 180.22 driver :slight_smile:

One of my friends told its faster than xfce! :cool:

I disagree, It is fast but I compared and xfce is still faster. :cool:
I like the kwin in kde 4.2 . Only thing if I use compiz even in xfce it is losing the decoration of some kde 4.2 apps like in the case of dolphin. I have to use kwin as the window manager to regain the decoration. The unbeaten part of this new kde is the look and feel IMOHO. It really made my 4-eyes (including my reading glasses) keep on shining for several hours while using it. Just don’t know for others because the people in the house still prefer xfce:)

The new driver makes a substantial difference with the desktop experience in KDE 4.2, and Qt 4.5 will take it even further.

My only gripe is that, for the first time in longer than I can remember, I no longer have suspend using the nvidia driver. In fact, it broke for many people that had no issues with the previous versions. The devs apparently replicated and acknowledged the problem during beta testing, but couldn’t get a fix in before release. Bah.

Fortunately, I can get by with hibernate, but lack of suspend could be a deal killer for those affected.

Just my 2c…


Sorry if this is kind of an off topic question. But I didn’t want to start a new thread for my question.

When KDE 4.2 is released on 1/27, will suse 11.1 have an easy way of upgrading from the current 4.13 to 4.2?

What I mean is, no adding repos from unstable or even from factory. Will it be a one click or add a few repos? And once added, can 4.13 be removed???

I am reluctant to give my father and law the 11.1 disc with the problems in KDE 4.13. Ideally, I would want to give him a suse 11.1 disc with KDE 4.2. Is that a possibility?


Sounds great about the improvements over 4.13. I can’t wait.

There won’t be an automatic update they will stick with 4.13 until 11.2.
You will find one clicks in the kde repos.
If you install 4.2 it will overwrite 4.13 you can’t have both AFAIK


Where are you getting the 180.22s? I have downloaded them three times from Nvidia’s site and installed the manual way, but they don’t update the kernel version, so they don’t work. If I check the log, it gives the kernel version of the last good install of Nvidia I had (such as 177.82 and 180.17).

I’ve been installing the Nvida drivers for years this way, and this has never happened to me before.

I got them to install using YAST, and they are indeed much zippier in 2D mode in KDE 4.2. Still not sure why the binary version didn’t work this time.

I have some problems with hotkey configurations on my laptop (keyboard layout switching) so, I’m reverted is to 4.1.3. BTW the performance of KDE4.2 is better.

I just added the nvidia repo and did it the easy way in yast


@conram: I have the nvidia 180.22 drivers and KDE 4.2.0 “release 82.1” and my gkrellm isn’t transparent. the invisible theme isn’t invisible.

What could be wrong? did you have to re-install gkrellm and/or nvidia drivers?

I installed KDE 4.2 and then Nvidia 180.25. That solved my issues. Then 2 series of updates of KDE 4.2 (yesterday) caused the issues to reappear (X fails to restart when logging out thus enforcing reboot).

There was another update to KDE 4.2 today and that did not rectify the issue.

Then a new driver arrived today - Nvidia 180.27 - and that did not solve anything.

Anyway, based upon the latest merits I suspect that the trouble is caused by modifications to KDE 4.2 made by OpenSuse after the initial release.

Tried the KDE 4.2 live, runs ok. Is the one click Nvidia driver install working with 4.2? The kernal listed the same as 4.1. Have 4.1 now runs excellent on Nvidia 177 driver from one click.

From runlevel 3. Delete the nvidia.ko file

rmmod nvidia

rm -rf /lib/modules/

Your kernel version may be different.

Then install the drivers from Yast.

Well, for now I have to disagree. When I installed a fresh 11.1 with kde 4.2 and the nvidia 180.22 drivers, the screen ‘repaints’ badly and renders KDE unworkable until I reboot. Text disappears from the screen and windows that were first behind each other are now somehow mixed. This phenomenon happens after a random period of time.

At the moment I blame the nvidia drivers, because I just found out that the same thing happens with KDE 4.1 and so I’m going to try 171.06.01

It could be some kind of sync problem, but I’ve selected the kind of screen I always select: standard lcd->1920x1200@60hz
To be honest, it remains a mystery what kind of screen I have (Lenovo T61p: website says it’s either an lg or samsung :sarcastic: )

Anyway, I’ll let you guys know how the 171.06.01 works out.

To follow up on the driver issue: It is definitely that, a driver issue.
Because of uni stuff I quickly tried to install 170.* without luck, but I missed the post from brucecadieux above mine.

Anyway, I switched to the nv driver and now 4.2 runs without problems and very snappy indeed. I still have to install the original nvidia drivers, because I need XVideo. But that’ll be ok.

For the record, I have a NVidia Quadro FX 570M.

I installed opensuse today with the simple intention of checking out KDE4.2 and it turned out okay in the end, though not without a bit of adventure. The factory CD wouldn’t boot, and neither would the factory net install CD. Then I installed 11.1 and completely borked it when trying to add/update the factory repo.

But it’s all good now after a reinstall. The one-click nvidia thing worked from 11.1 (KDE4.13) and then the one-click KDE4.2 link that I got from this thread worked fine, too. Now I’m maybe going to pry myself away from Openbox and start liking KDE for a while. It’s really not too bad, though still a little awkward for me.

Anyway, thanks for the advice I got from this thread. This is the first time I’ve kinda liked KDE in all my years hacking at Linux.

I’m even on topic—nvidia 180.22 is pretty snappy indeed, though not as snappy as on my beloved Openbox <:)

nvidia 180.22 has a resume bug so dont use it with kde4 on you laptops.

I am running 180.27 / KDE 4.2 and it is fast.