KDE 4.2.3 latest DUP result strange error while loging in X

I installed latest dependency update (zypper dup) to the opensuse 11.1 64 bit. After post installation restart, I cannot login to sytem and X says in a window:

**Logging in UserName...
Authentication failed **

Do you have the same issue or it’s something about that I changed with yast at login Manager. Regards.

Do you have anything other than English enabled?
If that is the case, try to type in the login name (do not click and select) and then type in the password.

No, everything in english. Actually, automatically login in enabled, so I don’t enter any username or password while the X is starting.

I tried to start it in FailSafe mode, then entered my username&passowrd to the console, then tried to start x (with startx command). It turned to black screen at the end of loading the things to start X (for kde interface, as you know it start with a small hdd image than continue until a big kde logo, my system failed at that kde logo).

By the way. that DUP was included some Compviz updates. Before the updates I disabled the compiz because it was failed on my system.

I also tried to remove all compiz components at failsafe console, but didn’t work.

Isn’t it a good method to use “zypper dup”, cause it sometimes results this kind of problems for me. I think I should just use “zypper up”.

For this type of login problems, is there a way to recover to a stable state like Windows does?

“zypper dup” is generally bad with the current version of KDE. There are too many badly connected dependencies. You should have done only “zypper up”.

You may log in with out GUI (just type 3 when the boot menu comes up and press Enter) and try to delete the .kde4 directory. Warnings: This will delete your earlier desktop settings, mail settings etc.

rm -fr .kde4

At this point, you can do “zypper” commands if you want to remove anything further.
After that, reboot.