kd3-knemo in 13.1 with kde 4.11.3

I am sure someone knows this right off. Does kd3-nemo work with opensuse 13.1 with kde 4.11.3? I installed just the plain knemo, thinking that would be enough. It apparently runs, but no gui, no info or statistics showing. I also typed “knemo” in a terminal, and got back the answer that knemo was already running. So would installing kd3-nemo be OK in opensuse 13.1 (kde 4.11.3) or would there be a conflict? Thanks for any help.

It should work, but so should the KDE4 version of knemo.

It should add a icon to the system tray, click on this to get information, right-click to configure and quit it.

The KDE3 version works exactly the same AFAIR.

I would rather stay with the KDE4 version since it’s not unmaintained for years, but in active development.

Unfortunately, so far, it seems the KDE4 version doesn’t add an icon to the system tray. I’ve looked for it even among the hidden icons, but no luck. Perhaps a future update of knemo will fix this. I will hold off using the kde3 version for the time being.

All this on 12.3/KDE 4.11.4:
I installed knemo (KDE4 version), dragged the knemo.desktop file to my Desktop from /usr/share/applications/KDE4 and clicked to start it.
I see a brief flash of something on screen, which then disappears, same as what MoeNeigh reports.

I use ksysguard (a.k.a. System Monitor) for system monitoring and can see knemo running as a process.

MoeNeigh - ksysguard may provide the Network info you desire under its System Load Tab.

I’m using the KDE4 version since years and always had icons in the system tray:

Maybe try to remove ~/.kde4/share/config/knemorc after you killed knemo and restart it, it should show a default icon then.

I tried wolfi’s suggestion, killed knemo (using ksysguard), removed ~/.kde4/share/apps/knemo/knemorc.
Restarted knemo
Still no icon
I am a bit surprised to see that a new knemorc has not been created, I forgot to look at it before I deleted it.

Not a big deal to me, just an observation

OK, I tried that as well now, and can confirm this behaviour.
I quit knemo, removed the configuration, started it again, and there was no icon.

So there seems to be a bug indeed.

As workaround, create the file ~/.kde4/share/apps/knemo/knemorc with a text editor (when knemo is not running) with the following content:


Replace “eth0” with the name of your network interface.
You should get an icon then, and can configure it to your likings.


Sorry for reviving this old thread, but I got news.

The bug has been fixed a while ago, knemo now shows an icon for an existing network connection, even if there is no configuration yet.
I’m going to submit the fix to [noparse]KDE:Extra[/noparse] do that it will be in 13.2 as well, but I don’t think this warrants an update for released versions. As I found out in the meantime, you can actually reach knemo’s settings in “Configure Desktop”/“Systemsettings”->“Network Settings”->“Network Monitor”, even if no interface is configured (i.e. no icon is shown). I don’t know why I didn’t notice that before…

Also the fix causes some problems/confusion I think:

  • if you right-click on the automatically shown icon and choose “Settings”, the interface list in the settings is still empty. You have to add the interface manually to be able to configure it.
  • if you configure something else in the settings (f.e. the information that’s shown in the tooltips), the icon suddenly disappears if you didn’t add the interface manually, as knemo then saves its settings with an empty interface list.

I hope I can get that fixed/changed as well until 13.2 is released… :wink: