K3B unable to find transcode

Running KDE on Leap 42.2 I have both K3B and transcode installed via Yast however when I try to rip the video on a home made DVD K3B says it cant find transcode. Does anyone else see this or have an idea as to how to fix it? I should point out that dvdrip does find transcode just fine.


Install transcode from packman?

Opp’s my bad… I see you have it installed… So the k3b is from packman too, is it the latest (rebuilt a few days ago).

Just before I saw your comment I tested this on Tumbleweed as well and it failed. TW K3b is from packman at 17.04.1-11.1 and transcode is also from packman at 1.1.7-3.3. Neither show any updates. Not sure about the Leap 42.2 system as I just turned it off when TW failed as well.


Well the 42.2 version was fixed since it wasn’t building… But since it fails on Tumbleweed, guess the change isn’t it…

If you start it with strace (or maybe gdb), does it show where it’s looking for transcode?

From Changelog:

 * Deprecated transcode - tried to PR but unmaintained by upstream (BUG: 360170)

and from libk3b/core/k3bdefaultexternalprograms.cpp

void K3b::addTranscodePrograms( K3b::ExternalBinManager* m )
    **/* **Deprecated transcode
    static const char* const transcodeTools] =  { "transcode",
                                             0, // K3b 1.0 only uses the transcode binary
                                             0 };

    for( int i = 0; transcodeTools*; ++i )
        m->addProgram( new K3b::TranscodeProgram( transcodeTools* ) );
   ** */***

→ No support for transcode.



To whom it may concern

cat k3b-reenable-transcode.patch 
--- libk3b/core/k3bdefaultexternalprograms.cpp.orig     2017-06-05 21:05:25.000000000 +0200
+++ libk3b/core/k3bdefaultexternalprograms.cpp  2017-06-11 19:59:44.911382521 +0200
@@ -45,7 +45,7 @@
 void K3b::addTranscodePrograms( K3b::ExternalBinManager* m )
-    /* Deprecated transcode
+//Reenable transcode, although of dubious value by now    /* Deprecated transcode */
     static const char* const transcodeTools] =  { "transcode",
                                              0, // K3b 1.0 only uses the transcode binary
@@ -57,7 +57,7 @@
     for( int i = 0; transcodeTools*; ++i )
         m->addProgram( new K3b::TranscodeProgram( transcodeTools* ) );
-    */
+/*    */


P.S. And don’t ask my about the why/who/what/where of the patch above, I will not submit anything to anyone.**

Well, the upstream maintainer of k3b chose to disable transcode support because transcode apparently was not working any more:

The question is, would it work with Packman’s transcode?
Can anybody actually try this please?

I created a k3b package with Akoellh’s patch.
For 42.2 standard it’s here:

For other supported distributions, see this and choose your poison:

Please try to install that package and report back if transcode works then.

If yes, I’m inclined to reopen that bug report, or at least re-enable it in openSUSE’s k3b package via a patch.


I’ll try that version on my Leap 42.2 laptop later.


Well on 42.2 ripping a home made DVD not encrypted it works fine. I do wonder if the problem was an encrypted DVD that failed.


You probably used k3b 2.0.3 from the standard 42.2 repos?

I just tried myself here with 17.04.2, and can confirm that ripping a DVD doesn’t work at all because transcode is “not found”.
The patch does fix that, and a quick test here ripped a title succesfully.

I guess I’ll add the patch to our package then, though another confirmation would still be good too.

And a bug report should be filed upstream at bugs.kde.org too (I may do it myself in the next days), the current behavior is irritating at best. If transcode support is removed, it should not ask for installing transcode at the same time (which won’t help anyway).
And of course it would be nice to be able to rip using other tools (ffmpeg e.g.).

PS: https://bugs.kde.org/show_bug.cgi?id=381131


Especially as ffmpeg has become what transcode was before, the “swiss army knife” for Video/Audio conversion and is very actively maintained.

As K3B already has a plugin using the ffmpeg libraries (though only used for WMA at the moment), it would be a (the?) logical choice for that task.

With the “concat” filter ripping a DVD with ffmpeg is pretty straight forward (and certainly not more complicated than using transcode on the command line).

For example:



FYI: transcode support is re-enabled in the devel project (KDE:Applications) now.
Packman’s k3b package will inherit this (also for 42.2) as soon as it lands in Tumbleweed.

And it seems we managed to “pursuade” the upstream maintainer/developer to re-enable it too, at least until ffmpeg support is implemented… :wink:

I had this problem a while back, along with some other issues getting multimedia codecs to work. Switching the system packages to the packman repo solved the problem, so you can try that and see if it works.

YaST > Software Management > Repositories tab: Under name, select Packman Repository, then above the window on the right there will be a message stating, “Switch system packages to the versions in this repository.” Click that, and then click accept.

Try that and see if it works.

Also, someone should move this thread to applications.

In this case it’s exactly the opposite though.

The (old) k3b in the standard repos works fine, the newer version in Packman has transcode support removed.
But again, it will be “fixed” soon.

Also, someone should move this thread to applications.

If you think threads should be moved, it’s better to click on the “Report Post” button below a post (triangle with a ‘!’ inside) instead of hoping that some moderator will read your post by chance.

I agree that it would be better suited in “Applications” though and will move it. (“Multimedia” might be appropriate too)

This thread is CLOSED for now.

Thread moved to “Applications” and reopened again.

FYI, transcode support is enabled again meanwhile in Tumbleweed and Packman, 42.3 will follow soon.
(the 42.2 package was not affected anyway, as it’s an older version)