K3b No Optical Drive Found as Regular User - Root is ok

I am currently running openSuse 11.4 with KDE 4.6. Kernel version is Linux x86_64.

When I start k3b as a normal user, I receive the error “No optical drive found”. If I start as root, no problems.
This appears to be some sort of permission problem, however, I have already changed permissions to match the k3b recommendations.
Also, my user is in the cdrom group as well as in the burning group.

If I call k3b from a terminal window I get the following;

KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, 
this usually means you tried to call i18n related functions before your main component was created. You should not do that 
since it most likely will not work QStringList Solid::Backends::UDisks::UDisksManager::allDevicesInternal()  error:  "org.freedesktop.DBus.Error.Disconnected"

I have only been using Linux for about 11 months and will appreciate any guidance which may help resolve this issue.

You shouldn’t even be logging in as root, ever!

Try creating a new test user account
Login with it and test k3b
report back

Sorry for the misunderstanding. I NEVER login as root. I login as a normal user and then, if the situation warrants, I “su -” to root or use sudo. I apologize for not being very clear on what I meant when I try from root. What I failed to say was I open a terminal window under my id, su to root and then type k3b. I do not get the “org.freedesktop.DBus.Error.Disconnected” when I use this approach and it has no problem finding the dvd drive.

When I use my id to either launch from the launcher menu (hope that is the correct terminology) or I launch from a terminal window I cannot find the drive. The reason why I used the terminal window to launch k3b was so I could see any errors (I have used this process to identify permission problems in the past).

I did try under a second id and the same problem occurs.

I get the same error starting k3b in a konsole
But k3b works fine here. So I’m not sure the error and your problem are related.

I seen this before where only by switching to su -
Will k3b work

But never yet have I had such an issue. And if it happens the same with a new user. I suspect the problem is deeper than user setting.
Oh, and I didn’t alter any settings in user groups, never do (except for virtual box)

Not sure what to suggest.

UPDATE: I reinstalled DBUS and HAL which seemed to fix the problem.
I am, at the same time, both happy and sad.
Happy that the problem has been resolved, but sad that a reinstall was necessary.

Thank you for your assistance.

Hope that sticks
Thanks for posting back with that info

On 10/14/2011 01:16 AM, caf4926 wrote:
> You shouldn’t even be logging in as root, ever!

But if we don’t how can we get the true Windows experience? :wink:

Kevin Miller - http://www.alaska.net/~atftb
Juneau, Alaska
In a recent survey, 7 out of 10 hard drives preferred Linux
Registered Linux User No: 307357, http://linuxcounter.net

> But if we don’t how can we get the true Windows experience? :wink:

you have a point there!!

openSUSE®, the “German Automobiles” of operating systems