K3b is unable to detect my CD/DVD drive


I recently upgraded from a CD burner to a DVD burner and was absolutely delighted when I found out that K3b
burned DVDs as easily as CDs. I didn’t have to configure
anything. That was with SuSE 9.3.
I just installed 11.1 and now K3b is unable to detect my
CD/DVD drive.
yast uses /dev/sr0. I tried adding that as device, as well as /dev/cdrw, /dev/dvdrw, and /dev/dvd, to no avail.

Hardware information tells me the following:
DVD A DH20A4H (/dev/sr0)
Driver: pata_via

I could use some help here.

Thanks in advance, Stephan

See if this helps:

Solved : K3b Problem with Normal User on openSUSE 11.1 | Spirit of Change

Thanks, that helped indeed.
I had started it using the application launcher and I didn’t see a hint that this might be a permission problem. After I read what you pointed me to, I started it on the command line and saw the rather detailed error messages. I’m now burning as root, and will change permissions afterwards.

Thanks again, Stephan