k3b and amarok problems

I went thru the multimedia install procedures. I ran mmcheck. I still have major issues trying to

  1. load cd songs into a playlist and playing them
  2. rip music from a cd onto the hard drive
  3. move music from a cd or the hdd onto my ipod.

System is 11.2, kde 4, stock off the 11.2 install cd - that is, stock other than adding multimedia etc.

Ripping: k3b is having issues with lame. This has been noted in other threads. While the recommendations helped at least get k3b to make mp3 files - they are trash. Orb voggis files are fine - but they don’t work with the ipod stuff. Also, I have tried other rippers listed in the opensuse repos - this is for my wife - it must be gui - and everything else I’ve looked at doesn’t rip or convert.

Playing cd: I can get the cd songs to play in other programs - Amarok won’t move the cd files to the playlist to play them. So why do I want Amarok? It shows all the metadata that we want to work with and retain for the ipod. Metadata - this moves us to gtkpod.

Loading the ipod: gtkpod won’t load from the cd - it’s “not local” - which is what moved me to try and rip to the hard drive.

So - I’m stymied. After spending about 10-16 hours, we finally have:

sound and the abilitiy to play music, get the hardware manager to see and mount the ipod, use gtkpod to view the ipod contents - in ipod compatability mode - so that the ipod database is used.

I can’t rip from a cd to mp3. Any answers are appreciated - but I guess the ripping seems to be the 1st big problem to resolve - unless you know what I should do to get gtkpod to use the cd directly, like it should.

You need to search on Asunder and install it (in my opinion) if you want to rip CD’s to MP3’s. It worked for me when the others you mention did not work. I use Amarok to play MP3 OK and it even allows tag modifications, but not good at ripping CD’s. In general, if you use KDE, KsCD works OK to play CD’s, but really, you just need to rip the CD’s to MP3’s and play them as MP3’s from a program like Amarok.

Also, do you have more than one optical drive? If so, odd things can happen that can keep the selected drive from playing or ripping CD’s, take a look at this thread on drive naming.

Multimedia Optical Drive Naming (ie /dev/dvd & /dev/cdrom) Howto in opneSUSE

Most often, having a single DVD/CD drive is your best option in Linux for some reason.

Thank You,

Only one optical drive.

Asunder - I will give this a try, and report back. Since gtkpod won’t do the ripping directly - I too am of the opinion that if I can get the rip to work, all should again be peaceful on the domestic front.

Actually, slightly ot, but on the domestic front vein - I have left my wife’s computer in Windows for eons, just because it was the simplest solution. She is big on media - music is her career. One time I did try to get a dual boot working - installed Mint because of the media bit - but the install ran about half-speed - a wierd result, and not a go for her. At some point, on a day when I had a few hours, I installed 11.2 over the mint, and got some basics working to her style. It sat there, unused, for the past few months - until, one day, a couple of weeks ago, Windows broke. I booted the 11.2 and said “here ya go, it’s working!” and all was fine with her. She was working and and able to do Facebook, so the world was good. But, eventually, the ipod has to work - she uses it for her work. So, what started out as a problem, then became a lucky incident in disguise, was threatened with being a problem again.

Thank you.

One other thing - other people have had similar issues with k3b. I googled and found threads, elsewhere, about this. Apparently lame will do the job correctly from the command line - but not when k3b issues the command.

I realized this morning that I should probably try to use lame from the command line, and see if I get decent mp3’s or not.