K application launcher and screensaver

Hello I have two simple questions… first off any ideas as to why the k application launcher doesn’t save any of my favorites? and number 2. I started off with kde3 but decided to try 4 well I was having problems with kde3 apps popping up in 4 (two powersaves two kmixers ect) so I deleted everything to do with kde3 except when my screensaver comes into effect I am prompted by the kde3 screensaver program to enter a password to log back to my session. how do I fix these problems…also it seems that alot of kde apps are preventing me from doing what I want such as configuring the panel and such how do I fix this?

Deleting all that kde3 stuff without sufficient knowledge is probably not good.

Try this from outside X

mv /home/username*/.kde4 .kde4old
mv /home/username*/.kde .kdeold

replace username* with your username

alright did that and it changed the look of things abit it didn’t solve my “application launcher” problem. The screensaver problem is fixed, but my kde application launcher is still not “recording” my favorites…any ideas?

You are aware you add and remove items to the favs section of the launcher, it’s not a history as in Start - Recently Used

Oh…no I wasn’t wow I feel like an idiot…but anyway after doing what you said I change my time format from military to standard am/pm but “country/Region & language” is not wanting to acknowledge my change I’m still getting the time displayed in military format after logging off then on…any ideas of what the problem might be?

You mean change from Hundred Hrs to 12 hr clock. I’ll have to get back on this. I have to log out. Maybe someone else will spot it and answer.

Just curious, did you remember to click apply before rebooting?
Overkill somewhat but I rebooted, not relogged WFM.

oh yes,sorry it’s called military time here but yeah, I figured it out…turns out I was using the kde3 setting and not 4 just went to configure desktop then regional&language settings and it worked…would be nice though if the kde guys just put that setting in the digital clock settings where it belongs, but anyway onto other issues…once I explore them a little more,and am still unable to figure them out I’ll post…but thanks for your help

Well **** I take it back…it’s still prompting me for a password after the screensavers been on for 15 minutes…my old setting in kde3 (I’ve since then disabled the kde3 screensaver program, but it’s ugly head still keeps popping back in) anyone have any ideas on what files I should check out to get this fixed?

In Yast if you search for ‘powersave’ are there any installed there?

nope don’t have any of em installed

And you are certain the powersave application starts up in kde4, even though powersave is not installed:

to tell you the truth no I’m not how do I go about check this out?

The ways to fix the the power settings in kde4 is in Configure Desktop also. Just like the other settings they’re in weird places.
For Powersave
1.Open Configure Desktop
2.Click the Advanced Tab
3.Look for a light bulb icon
If you click Edit Profiles it’ll tell you what each of those items like presentation & powersave mean. The Defaults there should serve you well.
Back on topic:
The screensaver timing setting is under the General Tab
1.Click the Desktop icon
2.Click Screensaver you’ll then see there is a start automatically check box.
once you see it you’ll know how.

alright yes I’ve checked all these and the settings are what there supposed to be…like I said before the "requires password to stop box is not checked yet I am required to enter a password to stop the screen saver. also, an interesting note, when I go to resume my session the screen doesn’t black and bring up the enter password dialog box it just sort of hangs in the background “flashing” with the screensaver still going…so whats the next step

Do as I show in post #12 Open Yast - Software Management
search powersave

post the screenshot

oh ok nevermind it was what you told me to do in post 14 except I seemed to miss some of the settings (guess that’s what happens when you stay up all night trying to figure it out) I just had to change the "when system is idle for __ setting to do nothing. thanks for your help