Java configuration console

Using KDE and Firefox

I’m trying to install a program.
It should be downloaded and installed with java.
I am using a proper Java version, there is no problem of old Java versions.
After the download of the program the java refuses to install, showing a message saying that there is no security.
When this happens on Windows machines, just open the Java configuration console and register the site from where the file is being downloaded.
I was informed that the solution for Linux is to do the same thing, and to open such a configuration console should open a terminal, access the folder with the Java installation and type


But nothing happens.

Maybe I have not found the correct Java directory … I found the directory below …


Please tell me if this is the right directory.
How do I solve the problem?

Thanks in advance

Please do not apply Windows methods on linux, not even with java apps.

Can you show us actual output of your attempts to get the program running ? Copy and paste the output here, between CODE tags, the # in the layout ribbon.

When running the Java application, I used the “-nocurity” option but it also did not work.
This application downloads and installs a Brazilian government program to issue invoices for commercial use.
Apparently the program works well until the moment it tries to install the Government program … and then the error occurs … and the window below appears …

And this is what is returned after the error:

positivo:/home/sergio/Downloads/emissoNfe/sebrae # javaws emissorNFehomologacao.jnlp
Unable to use Firefox's proxy settings. Using "DIRECT" as proxy type.
netx: Initialization Error: Could not initialize application. (Fatal: Application Error: Cannot grant permissions to unsigned jars. Application requested security permissions, but jars are not signed.)
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize application. The application has not been initialized, for more information execute javaws from the command line.
        at net.sourceforge.jnlp.Launcher.createApplication(
        at net.sourceforge.jnlp.Launcher.launchApplication(
        at net.sourceforge.jnlp.Launcher$
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Cannot grant permissions to unsigned jars. Application requested security permissions, but jars are not signed.
        at net.sourceforge.jnlp.runtime.JNLPClassLoader$SecurityDelegateImpl.getClassLoaderSecurity(
        at net.sourceforge.jnlp.runtime.JNLPClassLoader.setSecurity(
        at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(
        at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(
        at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(
        at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(
        at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(
        at net.sourceforge.jnlp.Launcher.createApplication(
        ... 2 more

to be sure, is it: -nocurity or -nosecurity

Sorry, I typed it wrong here, but I made it right in the attempts and nothing worked

In addition:

I used a simpler browser, the Konqueror that comes with the distro OpenSuse

This time the installation went a little further, gave the same error, but clarified a little more by presenting the window below:

When I click on “More Information” I’m directed to an Oracle page that shows the problem for the Windows and Mac platforms

Summary of the opera … we are without any help …

Can you tell me how to solve it?

Finally I was able to find the Java configuration window installed with the OpenSuse repositories

Probably this solution is also suitable for other distros

I removed everything that refers to java that was installed via OpenSuse distribution

I installed the latest version of Java as instructed directly from Oracle

After many hours, I found the file that opens the java configuration console … Below is the link


Now just make the settings …

I hope it passes to OpenSuse users

Double-posting is generally discouraged in these Forums…

To assist future people who might run into this issue about running unsigned applets,

Although you can install Oracle Java which includes a tool which can modify security,

With openjdk, the console is a lot less capable,
To address this issue about unsigned applets, you can follow follow the steps described in this post