Jarnal doesn't start

Hi guys,

I’m having a funny problem that I tried several solutions with no results.

Suddenly Jarnal is refusing to start.

I removed the complete folder, downloaded jarnal-install.zip , and extracted it.
I changed the properties of Jarnal.sh to be executable… but still it doesn’t even respond to the clicks. The funniest thing, other .sh marked as executable on clicking opens in text editor! but not jarnal.sh
I got Jarnal from Jarnal Downloads

Any help highly appreciated.

What openSUSE version are you using? For 11.3 Jarnal is in the repos and can easily be installed with (assuming you have done su - first):

zypper in jarnal

thanks lot for your help…

but out of curiosity, what does this command do? aaah… zyper to install… sorry for being that hmmm… sleapy.
Just keen to learn from your experience.

what about instructions shown on their webpage and downloading from there? extracting… changing jarnal.sh to be executable
It was working before. What might have caused that?

I’m not sure why it wasn’t working now. Can you run it from the terminal?

cd /path/to/where/jarnal/is/extracted

it says:
jarnal.sh: command not found :frowning: !!!

What is output of



This is the output of ls where jarnal was extracted:

jarnalannotate.cmd jarnalannotate.sh jarnal.command jarnal.sh templates
jarnalannotate.command jarnal.cmd jarnal.jar lib

I highly appreciate your prompt replies… it’s wonderful

No problem :wink: - Anyway in that directory where jarnal is extracted try this:

bash jarnal.sh

Does that work?

I just downloaded jarnal-install.zip and let it extract to my Downloads folder. I then when in to Konsole (Terminal) and did:

cd ~/Downloads
bash jarnal.sh

And it seemed to work fine. Let me know if you can run it like:

bash jarnal.sh

though this means problems but it sounds great, I feel we’re getting closer

Exception in thread “main” java.awt.HeadlessException
at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:173)
at java.awt.Window.<init>(Window.java:437)
at java.awt.Frame.<init>(Frame.java:419)
at javax.swing.JFrame.<init>(JFrame.java:218)
at jarnal.Jarnal.newJarnal(Jarnal.java:728)
at jarnal.Jarnal.initJ(Jarnal.java:706)
at jarnal.Jarnal.main(Jarnal.java:476)

What java are you running?

what is the output of:



java -version


This was what I did several times.

Do you think as per the previous result I posted there is a problem with java installation on my machine?

java version “1.6.0_20”

and echo $DISPLAY



sorry if I’m messing things… I’ll try concentrate better

no thats fine :slight_smile: - I recommend you trying out mmcheck:
MultiMedia Checker or mmcheck - Check Your openSUSE MultiMedia Setup in Just 16 Steps

And see whether it is the correct version of java with that tool

ok… I’ll check that…
so you believe the problem is with java?

It could be. I’m not 100% sure. However I ran Jarnal fine here without any error (openSUSE 11.3 64-bit)