iw reg set

Hi, every1,
After battling some time to get my card work I realised that my AP uses channel 13 to communicate and there are only 11 channels enabled. So I installed iw. But when I am running the most of commands for ex. iw reg set SE, I am getting an error operation not supported(-95). Counld’t really find a solution to this. Found something about ACLs. Way to complicated for a newbie.
Is there any solutions for this? Or can I enable channel 12-13 in any other way? (google came with an answer to add lines in to files that i didn’t have).

Distribution?

Kernelversion?

Wireless card?

Wireless Driver?

Dist openSuse 11.1
Kernel 2.6.27-0.1
Card D-link DWA-547
Driver ath9k


su 

password

echo "options cfg80211 ieee80211_regdom=EU" >> /etc/modprobe.d/cfg80211

modprobe -rv ath9k

modprobe -v ath9k

iwlist f

That is what I found in google. But I didn’t have /etc/modprobe.d/cfg80211 file. Anyway done the commands. Rebooted. Still 11 channels. That is why i tried to install iw.
Anyway if I use other drivers then ath9k. Ndis or madwifi, will channels be enabled there?

This should work on 2.6.27 for all new (mac80211-based) drivers and of course you don’t have that file, you have to create it.

The setting via iw will not work for kernel < 2.6.29 as nl80211 was introduced with 2.6.29.

Maybe compat-wireless packages might help, but if the card supports those 13 channels in g-band, it will not be necessary.

I have an Intel AGN 5300 here which uses “iwlagn”-driver (which is also based on mac80211) and it works exactly as described above.

bukuhr wrote:
> That is what I found in google. But I didn’t have
> /etc/modprobe.d/cfg80211 file. Anyway done the commands. Rebooted. Still
> 11 channels. That is why i tried to install iw.
> Anyway if I use other drivers then ath9k. Ndis or madwifi, will
> channels be enabled there?

They might, but you should be able to make ath9k work.

If this is your AP, you might consider setting it to channel 11. With
802.11b/g systems, the transmission has a band that covers the central
channel +/- 3, which is why channels 1, 6, and 11 are recommended -
they do not interfere with each other. On channel 13, you are using
channels 10 - 16.

It is unlikely that you have a permissions problem with a need to set
ACLs. What is wrong is that you have the regulatory domain set to US,
not something in Sweden. I think the version of iw does not understand
SE, but it should handle EU and give you those two extra channels by
entering ‘sudo iw reg set EU’. The only problem is that command would
have to be set with every boot.

Don’t know if I can setup it on any other channel then 13. I have only a wifi switch that gives ip adresses. But I will try to contact my provider and see if they can change it. Pretty bad looking to give channel 13 to me, when I see others APs from the same provider working on 1,6,11.
About iw. I get the same error operation not supported(-95) even if I run “iw reg get”, I tried EU as well. The same.
So since I can’t egt it work with “options cfg80211 ieee80211_regdom=EU”, the solutions I see so far is
-update kernel to the latest, try with iw again
-battle the cfg80211
-buy a router? :open_mouth:

I will continue to strugle tomorrow. Thanks for advices.

got it working. By now my system halts all the time.
Saw that it is common with wifi. But how to solve?

bukuhr wrote:
> got it working. By now my system halts all the time.
> Saw that it is common with wifi. But how to solve?

It is NOT that common. My system never locks up and I test 3
different wireless devices.

What device do you have? When your system halts, what are the
symptoms? Is anything logged in /var/log/messages?

I have a d-link dwa-547.
I think most of the times it freezes when i have firefox up. And it looks like my gui stops. I cant move my mouse, press any button on keyboard.
Turned off beagle, and gonna use different web browser to see if i will have any progress.
I also tried to change drivers. Had ath9k. Now using madwifis drivers.

Still freezes. Is there any logs I can read to find what is the problem?

bukuhr adjusted his/her AFDB on Sunday 07 Jun 2009 08:56 to write:

>
> Still freezes. Is there any logs I can read to find what is the problem?
>
>

Have a look round

/var/log/

mostly in

messages
xorg
Networkmanager

Does the system run OK if you do not connect the wifi?

When it locks do the keybord leds flash?

Can you drop to the console:

Ctrl+Alt+f1

when it is locked?

Does holding down

Ctrl+Alt

and pressing backspace twice do anything?

HTH


Mark

Nullus in verba
Nil illegitimi carborundum

It is completly ok while i am running wired connection.
The keybord do not flash and i can not drop xserver. Nothing I press on keybord works. But it feels like the linux itself still runs ok, but not the gui.

Didn’t find anything in logs. Just that it is still using ath9k even if i have installed madwifi.

bukuhr adjusted his/her AFDB on Sunday 07 Jun 2009 12:36 to write:

>
> Didn’t find anything in logs. Just that it is still using ath9k even if
> i have installed madwifi.
>
>

well I am no wifi expert ( all the wireless I use work out of the box )

(/smugoff)

However there may be somethings you could do.

Have just had a quick scan of your posts and ( this may be stoopid ) but
have you disabled ipv6 in KDE “and” firefox?

another tip, go to YaST>System>/etc/sysconfig Editor>System>Kernel>

and set the ENABLE_SYSRQ to Yes

Have a read here:

http://en.wikipedia.org/wiki/Magic_SysRq_key

The most important ones are the sync, unmount, reboot keys.

If you sync then at least you might not lose any data and have to sit
through a fsck on boot.

I do the “Reboot Even If System Seems Utterly Broken” That is the extra “S”
after system just to be sure so that is

Alt+SysRQ+

R
E
I
S
S
U
B

This can get you out of nearly all kernel crashes and back to a clean
reboot.

There are loads of other options too.

HTH


Mark

Nullus in verba
Nil illegitimi carborundum