Issues with old ATi card and radeon driver (image corruption, BUSType, AGPMode, et al. not used)

Hello again. I’ve recently installed openSUSE 12.1 on my old desktop machine with an old ATi Radeon 9200 graphics card. While one of the previous releases (11.3 I think) worked flawlessly, I’m having issues with my graphics card here.

Mainly, the graphics performance is much lower than before, and when I checked the /var/log/Xorg.0.log, I found this (among other)…

    24.049] (II) RADEON(0): Acceleration enabled
    24.049] (==) RADEON(0): DPMS enabled
    24.049] (==) RADEON(0): Silken mouse enabled
    24.049] (II) RADEON(0): Set up textured video
    24.049] (II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
    24.049] (WW) RADEON(0): **Option "BusType" is not used**
    24.049] (WW) RADEON(0): **Option "AGPMode" is not used**

Why are these options not used? Have they been deprecated? Have I done something wrong?
(I’ve put the whole Xorg.0.log into the pastebin, if anyone is interested.)

There is also some weird image corruption when the compositing extension is enabled, which is seen when left-click menus pop up. Something like this (screenshot).

Any thoughts or ideas regarding this are welcome. Thanks in advance!

Image corruption is common problem with 12.1, no matter what graphics card and drivers are you using.
Not everyone is experiencing this problem, though.
But that’s why i’m sticking with 11.4 (I have HD5670 and compiz is unusable).

Hmm. Okay, I guess I’ll just be patient then :smiley:
I’m not really into using “desktop effects”, be it compiz or otherwise. I just mentioned this as an issue, since I thought it may be related.

OK, so what’s with the “not used” options? Are those automatically detected, deprecated, or?
TIA :slight_smile:

On an old pc of my wifes with similar hardware (that she has subsequently given away) we used to specify those modes manually in her configuration files (on a much older openSUSE version). I posted abput this a few times a long time ago. I don’t have time to search for this now (I am posting this from my tablet).

I’ve done the same, actually. My /etc/X11/xorg.conf.d/50-device.conf file looks like this…

Section "Device"
	Identifier "Default Device"
	Driver	"radeon"
	BusID	"PCI:3:0:0"
        Option	"NoAccel"	"false"
        Option	"SWcursor"	"false"
        Option	"BusType"	"AGP"
        Option	"AGPMode"	"4"
        Option	"AccelMethod"	"XAA"
	Option	"XAANoOffscreenPixmaps"	"true"
	Option	"DynamicClocks"	"true"
	Option	"BackingStore"	"true"
        Option	"DRI"		"true"

	## Required magic for radeon/radeonhd drivers; output name (here: "DVI-0") can be figured out via 'xrandr -q'
	##Option "monitor-DVI-0" "Default Monitor"

Is there anything or anywhere else I should write something more?

Given you define bus type and AGP mode do you still get those same errors?

Yes. When I don’t define them, the log doesn’t say anything. When I define them, I get the message that they’re not used.
Which is odd, since I didn’t find any documentation saying they’re “deprecated” or “not used anymore”, or anything that would replace them (perhaps I didn’t search well enough?)
What’s really bothering me is the poor graphical performance and the regular graphic glitches that occur - with or without these options.
So essentially, my question is - what can be done about it (except buying a new graphics card)? Are there any other config files or logs which I could paste here, in order to provide you with more information?

I think you’re going to need to take your issue upstream and check/report the bug(s).

So wait… everybody has this problem who’s using the radeon driver?

Not likely.

More likely users with the specific legacy hardware that you have, are experiencing this problem. AMD have stopped supporting this hardware in both MS-Windows and GNU/Linux.

I have an old X300 radeon chipset in my personal laptop. I don’t experience the issue you’re describing, so as oldcpu suggests, this is likely to affect specific old chipsets. File a bug report. (There will come a time when old hardware like this simply will not be fully supported).

Should I even bother the developers with a bug report then?
I mean, my hardware is old, and requesting a continued support for this could have either no effect, or bad effect for modern hardware…

Okay, I solved it. At least the part about the xorg.conf options, and since the image corruption is supposedly a common problem, I’ll wait for that (as I have said before, desktop effects don’t really matter that much to me).

Anyway, it seems that the cause of my problem was KMS. Once I disabled it (I put the “nomodeset” option in my kernel line in /boot/grub/menu.lst), everything started “magically” working again.

Here’s my menu.lst now:

default 0
timeout 8
gfxmenu (hd0,0)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 12.1 - 3.1.0-1.2
    root (hd0,0)
    kernel /boot/vmlinuz-3.1.0-1.2-default root=/dev/sda1 resume=/dev/disk/by-id/ata-ST380011A_5JVANCEF-part6 splash=silent quiet showopts **nomodeset** vga=0x31a
    initrd /boot/initrd-3.1.0-1.2-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 12.1 - 3.1.0-1.2
    root (hd0,0)
    kernel /boot/vmlinuz-3.1.0-1.2-default root=/dev/sda1 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31a
    initrd /boot/initrd-3.1.0-1.2-default

(the failsafe option already had this)

So, yay! It works :slight_smile: thanks everyone for your effort and ideas.
(yes I know nobody mentioned KMS here, but some of your posts started my train of thoughts which led me to this. thanks.)

p.s. I’m stupid… how do I mark the thread as “solved”?