Issues with DELL Latitude E6410 - Core i7 M620 with integrated Intel HD graphics


I have been unable to get both opensuse 11.2 and 11.3 32 bit versions work properly on my DELL Latitude E6410 laptop.

With both 11.2 and 11.3 KDE Live CDs I get no graphical display when I attempt to boot into the Live system. VESA mode does not help either, only text mode works.
So I installed the system in text mode but during the first boot the screen went blank again.

One peculiar thing is that 11.1 installs and boots fine, what gives?

Is this even supported or I shouldn’t even try to bother getting this setup to work? Has anyone been able to run opensuse 11.3 on a Core i7 integrated Intel graphics system with X system working?


Should not make any difference, but why didn’t you use the 64bit version?

I had that one handy as I got the image from a friend, no special reason.

I currently do not have a fast enough Internet connection to download the 64 bit image, that would have to wait at least a week. Hence trying with the 32bit version for now.

Well, my friend had a Kubuntu 10.4 Live CD, so I tried running that as well, just to see what happens. I faced the same problem with Kubuntu 10.4, no display as soon as X starts.

Have you tried booting openSUSE in failsafe mode? Have you tried booting with ‘nomodeset’ added as a boot option ?

You may also want to look here SDB:Configuring graphics cards - openSUSE and here, /

Yes, I had tried booting into the live CD with ‘nomodeset’ option. I forgot to mention that, my bad.

How do I get a failsafe mode? Is it same as using VESA driver or is it something else? I guess there are several extra boot time options in failsafe mode that are not normally used (If memory serves, acpi=off is one of them). How do I acheive that with the live CD?

How do I get a failsafe mode? Is it same as using VESA driver or is it something else? I guess there are several extra boot time options in failsafe mode that are not normally used (If memory serves, acpi=off is one of them). How do I acheive that with the live CD? 

On a system installed from a livecd the failsafe option is available from the boot menu, At the moment I can’t check that it is there when booting the livecd, but I think so.
And yes, there are a number of boot options added by failsafe.

I’m wondering if this bug may be related: [Intel-gfx] 2.6.33 regression for intel hd in dell e6510, e6410 and possibly thinkpad x200s](

I note they are also struggling in Ubuntu with the e6410:

It might be worth while searching openSUSE bugzilla to see if a bug has been reported there on the e6410.

Thanks a lot for digging out those links. Yes, I will certainly check the bugzilla.

I will try with 64 bit version live CD of 11.3, as soon as I can and see if that fares any better.
I also found this thread Intel HD with openSUSE which might be related to my problem. I guess it is worth giving a shot.

I also found this link Running openSUSE (or any Linux distro for that matter) on Intel HD graphics seems possible.

Thanks for your help everyone.
I will report observations of my experiments with 64 bit version as soon as I can.

I was able to get X working with 11.3 64bit in VESA mode. The installation went OK but the first boot resulted in a blank screen, as expected. I somehow managed to finish that and after a reboot, was able too get a display with ‘nomodeset’.

Thanks again to everyone.

Well done in getting a work around for this. You could still write a bug report if you wish, and note the work around you applied. Still, I suspect the bug report will be quickly closed as this is likely an upstream problem beyound the ability of SuSE-GmbH to fix (unless there is a patch approved in Linus git tree that is simply awaiting implementation).

Out of curiousity, what driver do you have now with the ‘nomodeset’ ? Did it fall back to the VESA driver?

Without sax2 how should I check which display driver is being used?

In openSUSE-11.3, KDE has a ‘system’ icon one can click on that tells one what driver is in use. In addition, one can look inside the /var/log/Xorg.0.log file to tell what driver is in use.

I checked the log file, it seems to be using VESA

    17.925] (II) VESA(2): initializing int10
    17.925] (II) VESA(2): Bad V_BIOS checksum
    17.925] (II) VESA(2): Primary V_BIOS segment is: 0xc000
    17.925] (II) VESA(2): VESA BIOS detected
    17.925] (II) VESA(2): VESA VBE Version 3.0
    17.925] (II) VESA(2): VESA VBE Total Mem: 32704 kB
    17.925] (II) VESA(2): VESA VBE OEM: Intel(R)Ironlake Mobile Graphics Chipset Accelerated VGA BIOS
    17.925] (II) VESA(2): VESA VBE OEM Software Rev: 1.0
    17.925] (II) VESA(2): VESA VBE OEM Vendor: Intel Corporation
    17.925] (II) VESA(2): VESA VBE OEM Product: Intel(R)Ironlake Mobile Graphics Controller
    17.925] (II) VESA(2): VESA VBE OEM Product Rev: Hardware Version 0.0
    17.931] (II) VESA(2): Creating default Display subsection in Screen section
        "Default Screen" for depth/fbbpp 24/32
    17.931] (==) VESA(2): Depth 24, (--) framebuffer bpp 32
    17.931] (==) VESA(2): RGB weight 888
    17.931] (==) VESA(2): Default visual is TrueColor
    17.931] (==) VESA(2): Using gamma correction (1.0, 1.0, 1.0)

It looks like you may need to use the VESA driver until the problem is fixed upstream. I note this bug report for the Dell 6510 : which has references to the 6410.

Did you write a bug report on openSUSE-11.3 ? If it were me, I would write a bug report noting the “Intel” driver does not work, and you are forced to use the ‘nomodeset’ boot code in order to use the ‘VESA’ graphic driver.