Issues with both Wayland and Steam

Hi all:

I’m experiencing 2 issues that I feel are probably related. For general purposes, I am able to use X11 just fine, but when I try to do a Wayland session, it absolutely tanks my refresh rate, to the point of unusability. My screen will only refresh once every few seconds.

In addition, I’ve not been able to launch games using Steam successfully at all. I tried 2 games that both should work fine according to proton DB, but one completely crashed my system: it started loading then completely froze everything, had to kill and reboot my PC. The second one loaded but with about 1 FPS.

I’d read online that Steam was largely plug-and-plain on openSUSE, so a bit disheartened that I haven’t been able to get this working. Any ideas on what I could do? I did the Nvidia driver set up according to the start up docs and nothing was needed because the installation process handled it. I tried running a system update as well and nothing was due.

My set up is 2 Samsung monitors connected via HDMI on the GPU ports (by way of a KVM switch)
Details are:
Operating System: openSUSE Tumbleweed 20240419
KDE Plasma Version: 6.0.4
GPU: GeForce RTX 3060 Ti

Nvidia drivers:

I’m using the latest Flatpak version of Steam

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.