Issues playing videos in 12.3

So I have a bunch of .mkv files. If i open them up with mkvmerge and have a look, they are mpeg4 files. with audio tracks/Sub title tracks

They will Sometimes play in kaffiene… but most likely not, They do play in SMplayer, however sometimes they pause and then it force closes, giving me this (Yes watching DBZ :wink: ) :

-----------incoming wall o text o -----------
/usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xv -ao pulse -nokeepaspect -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 52428901 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/jordan/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -subpos 100 -volume 100 -cache 2048 -osdlevel 0 -vf-add screenshot -noslices -af scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /var/run/media/jordan/New Volume/Dragonball Z Kai Complete [Blu Ray]/Dragonball Z Kai 82 The Strongest Super Saiyan! Trunks’ Power Unleashed!.mkv

MPlayer dev-SVN-r35127-4.7-openSUSE Linux 12.3 (x86_64)-Packman (C) 2000-2012 MPlayer Team
Can’t open joystick device /dev/input/js0: No such file or directory
Can’t init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /var/run/media/jordan/New Volume/Dragonball Z Kai Complete [Blu Ray]/Dragonball Z Kai 82 The Strongest Super Saiyan! Trunks’ Power Unleashed!.mkv.

Cache fill: 0.00% (0 bytes)

libavformat version 54.25.104 (internal)
libavformat file format detected.
[matroska,webm @ 0xe17fa0]max_analyze_duration 5000000 reached at 5004995
[matroska,webm @ 0xe17fa0]Could not find codec parameters for stream 4 (Subtitle: hdmv_pgs_subtitle): unspecified size
Consider increasing the value for the ‘analyzeduration’ and ‘probesize’ options
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (ac3), -aid 0
[lavf] stream 2: audio (ac3), -aid 1
[lavf] stream 3: subtitle (pgssub), -sid 0, -slang eng
[lavf] stream 4: subtitle (pgssub), -sid 1, -slang eng
VIDEO: [H264] 960x720 0bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
Clip info:
creation_time: 2012-06-23 06:24:55
ID_CLIP_INFO_VALUE0=2012-06-23 06:24:55
Load subtitles in /var/run/media/jordan/New Volume/Dragonball Z Kai Complete [Blu Ray]/
ID_FILENAME=/var/run/media/jordan/New Volume/Dragonball Z Kai Complete [Blu Ray]/Dragonball Z Kai 82 The Strongest Super Saiyan! Trunks’ Power Unleashed!.mkv
Opening video filter: [ass auto=1]
[ass] auto-open
Opening video filter: [screenshot]

Opening video decoder: [ffmpeg] FFmpeg’s libavcodec codec family
libavcodec version 54.54.100 (internal)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)


Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)

AO: [pulse] 48000Hz 2ch floatle (4 bytes per sample)
[Mixer] No hardware mixing, inserting volume filter.
Starting playback…
Unsupported PixelFormat 61
Unsupported PixelFormat 53
Unsupported PixelFormat 81
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
[swscaler @ 0xf7b020]using unscaled yuv420p → rgb24 special converter
VO: [xv] 960x720 => 960x720 Planar YV12

mplayer: malloc.c:2369: sysmalloc: Assertion `(old_top == (((mbinptr) (((char *) &((av)->bins((1) - 1) * 2])) - __builtin_offsetof (struct malloc_chunk, fd)))) && old_size == 0) || ((unsigned long) (old_size) >= (unsigned long)((((__builtin_offsetof (struct malloc_chunk, fd_nextsize))+((2 * (sizeof(size_t))) - 1)) & ~((2 * (sizeof(size_t))) - 1))) && ((old_top)->size & 0x1) && ((unsigned long)old_end & pagemask) == 0)’ failed.

MPlayer interrupted by signal 6 in module: filter video

  • MPlayer crashed. This shouldn’t happen.
    It can be a bug in the MPlayer code or in your drivers or in your
    gcc version. If you think it’s MPlayer’s fault, please read
    DOCS/HTML/en/bugreports.html and follow the instructions there. We can’t and
    won’t help unless you provide this information when reporting a possible bug.
    --------------- finished text o ------------

Honestly I dont know what im reading exactly so, any help would be appreciated.

I have installed the pacman repo, from the 12.3 multimedia codec page thing… and ‘zypper up’ to get everything up to date. However, obviously have the same same issue.

Ideas? :slight_smile:

Please follow this

Hey! thanks for the reply!

However I did this already (basically as soon as I installed Suse)

“I have installed the pacman repo, from the 12.3 multimedia codec page thing…” – sorry I know that wasnt clear at all.

Did you use the switcher?

Where does that command line come from ? From smplayer ? Do you get the same if you simply play the video with:

mplayer /var/run/media/jordan/New Volume/Dragonball Z Kai Complete [Blu Ray]/Dragonball Z Kai 82 The Strongest Super Saiyan! Trunks' Power Unleashed!.mkv


Just did it now, I’ll see how it goes. It was weird though I had 2 packmans.

  1. Packman Repositories
  2. packman

switched it to #2 as per your photo… Not sure how I managed to do that . O.o

Edit: I went into bash and did a ‘zypper up’, and nothing was listed except for k3b? that normal? Before i did it and it listed everything from the codecs page.
Edit 2: still a black screen when I try and open the video in kaffeine, havnt tested playing a video in smplayer to see if it stalls and dies.

hey! sorry i missed your post. Yes it comes form SMPlayer (im guessing thats mplayer, sorry for not knowing all this quite yet). I havnt tried just opening the video from command line, when the video stalls and ‘crashes’. I get a pop up with dialogue box. Its not everytime is the thing, its only once and a while… Its weird. Is it possible that because its on slave hard drive its causing this? I have Suse on my SSD, and my storage stuff on a seperate HDD that i play from. I dont see how that could be an issue but maybe it is?

-> Tried using that line you posted and nothing happened.

Maybe we should see your repos too

zypper lr -d

For you sir:

zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/linux/packman/suse/openSUSE_12.3 |
2 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | |
3 | packman | packman | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_12.3/ |
4 | repo-debug | openSUSE-12.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/12.3/repo/oss |
5 | repo-debug-update | openSUSE-12.3-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/12.3 |
6 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | No | Yes | 99 | NONE | Index of /debug/update/12.3-non-oss |
7 | repo-non-oss | openSUSE-12.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.3/repo/non-oss |
8 | repo-oss | openSUSE-12.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.3/repo/oss |
9 | repo-source | openSUSE-12.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/12.3/repo/oss |
10 | repo-update | openSUSE-12.3-Update | Yes | Yes | 99 | rpm-md | Index of /update/12.3 |
11 | repo-update-non-oss | openSUSE-12.3-Update-Non-Oss | Yes | Yes | 99 | rpm-md | Index of /update/12.3-non-oss

That looks OK
You can remove repo 1 like this

su -
zypper rr 1

What about VLC? Playing the video?
Make sure you have the new vlc-codecs

Hey! alright repo removed. Vlc codecs was already installed, although before it didnt open in vlc; (a lot of weird errors came up before) however now they are playing which is a great start!

Is this cause we switched the repo to ‘packman’?

Still nothing in kaffiene. no video - audio starts for 10 seconds then the video dies.
Havnt tested smplayer.

I find kaffiene next to useless these days
VLC or SMplayer always

For kaffeine you need the package “libxine2-codecs”…

OP apparently followed my guide which does install that

Hm, for me kaffeine/xine work just as fine as VLC or MPlayer. (Not surprising, since they all use ffmpeg for most stuff in the end)

Well, maybe the problems are related to hw accelerated video playback then? (at least in the first post MPlayer is using the xv backend)
Are you using an NVIDIA graphics card and have installed the proprietary nvidia driver?
Then you have to add your user to the “video” group, see here:

It could of course also be related to pulseaudio.
Do you have libxine2-pulse installed?

DBZ kai is better

if you looked at the file line i am watching kai right now… wishing the buu saga was finished.

I have not installed the prop nvidia driver yet… not sure when i want to climb that mountain and go through turning off startx etc etc… makes me dizzy to think about after already trying to get a few things configured to get absolutely no where…

/frusterated… :slight_smile: sigh

Yes same here, for playback anyway. VLC and SMPlayer just have more features, settings, and viewable info.

Do you have libxine2-pulse installed?

That should be part of the default install (KDE) from main openSUSE repo. I haven’t switched that to packman. My multimedia is all working since I added vlc-codecs (packman) which also pulls in libxine2-codecs (packman) if not already installed. That saved me installing gstreamer-0_10-plugins-ffmpeg (packman), possibly.

Well, I think you should install the nvidia driver. It may well be that your video problems are caused by bugs in the nouveau driver you’re using…

To install the nvidia driver you don’t have to “go through turning off startx etc etc…” anymore.
It’s quite simple actually:
I would recommend “the repository way”, and check that the right kernel module is selected (f.e. nvidia-gfxG03-kmp-desktop for the **G03 **driver on kernel-desktop). I had it happen that the wrong one was selected automatically…

And be sure to add your user to the “video” group afterwards:

usermod -a -G video $USER

(replace $USER with your username)