Issue installing OpenSUSE-SLE-15.5-2024:0572-1

Hello,

I’m facing troubles installing one of the last update packages (see here).

I get the following error: the installed ghc-HsYAML-aeson-0.2.0.1-bp155.2.15.x86_64 requires ‘libHSvector-0.12.3.1-4ZUkvMG0hba9AHoOHt8bPP-ghc8.10.7.so()(64bit)’, but this requirement cannot be provided.

Any idea on how to fix it or manually install the missing package?

Many thanks for help!

Thomas

Sorry, but this is a bit unclear.
There exists openSUSE LEAP 15.5
There also exists SLE and maybe (i do not know) 15.5:0572-1, but SLE is NOT the subject of these forums. The link you provide also talks about SLE. Again that is not something many people here know much about.

So better find out what you are having there.

I think that’s the name of the patch. The “SLE” part is because this originates as a patch for SLE, but is also a patch for openSUSE. It does not show up for me in Yast online update, because I don’t have anything installed that requires this patch.

https://bugzilla.opensuse.org/show_bug.cgi?id=1220305

I do have installed SUSE Leap 15.5, not SLE at all… I don’t understand why I get this error message about SLE. Maybe a package coming from a repository.

If I launch the updates via Konsole, I get nothing to do…

This is the packages update tool that pops up this required update. I can’t choose not to install it for instance, as suggested in the bugzilla link suggested by @arvidjaar .

I enclose a few screenshots. Thanks again for help and advices!



update-tool

That was my misinterpretation because you did not show the commands you used and I saw SLE all over the place.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.