Is there an easy way to reinstall older versions of WINE?

It seems with Wine 4.1.3. that came with the last update Exact Audio Copy will no longer launch. How would one go about reinstalling the previous version?


Before doing that, it might be interesting to see what would happen if you reinstalled EAC instead. Just an idea.

I tried that before posting here, even tried an older EAC version, no change. It gets an ‘unhandled exception’ immediately at launch. Foobar2000 and other pC programs seem to still work.

Yes, try PlayOnLinux if you haven’t already heard of it.
It makes version management very easy and also allows you to easily set up independent prefixes for games/apps or groups.

It’s available though package manager and zypper.

The same thing can be accomplished with q4wine but you’d have to obtain old wine binaries yourself.

I’ve used PlayOnLinux in the past but could never get Exact Audio Copy to work with it. I just installed it and tried again and it still can’t run EAC. Part of the problem is once any version of WINE is installed it crashes when trying to install dotnet20 or dotnet40 which are required for EAC to run.
Hopefully they will fix it in the next WINE update. I was in the middle of ripping over 1100 CD’s and the 4.1.3. broke it after running EAC flawlessly for years.

You should install dotnet 2/4 with winetricks and not through installer if possible if I remember correctly.
That can be done easily by configuring wine prefix in PlayOnLinux.

According to Wine AppDb Exact Audio Copy has a platinum rating for wine version 1.9.16.
Or gold for later EAC version using wine 4.3.

So my suggestion is -
Create a new prefix for app with PlayOnLinux using wine version 1.9.16 or 4.3
Install dotnet library while you’re doing this by following wizard.
Install EAC.

If this gives you a functional app on PlayOnLinux (with their Wine binaries) then further system updates to wine should no longer affect it.

If you’re still having problems I suggest starting with a clean prefix to make sure you’re not importing problems from an old one.
You probably don’t need to install any further dotnet libraries if you’ve allowed Wine Mono install when setting up new prefix.
That should not be crashing.

I just found 4.14 and installed it and now all is well.

Thanks everyone.

4.14 has inverted my display so that some apps are displayed upside down for me.
That’s not a problem though because I just switch to previous versions of wine in those prefixes.