Is NVIDIA driver 390.157 compatible with Leap 15.4?

I have a desktop with NVIDIA geforce 9600 GT, which requires the driver 340.108. However, I read that this is not compatible with the current kernel in Leap 15.4, i.e., 5.14.21-150400.24.69. I am planning to replace the card with a geforce 430 GT, which is supported by the NVIDIA driver 390.157. Does anybody have experience installing the NVIDIA driver 390.157 in Leap 15.4 with kernel version 5.14.21-150400 and found that it works?

PS: I also tried the patched version provided by the website: openSUSE 15.5 / 15.4 / Tumbleweed NVIDIA Drivers Install Guide [535.43.02 / 530.41.03 / 525.125.06 / 515.105.01 / 470.199.02 / 390.157 / 340.108] :: If Not True Then False. However, the so patched NVDIA script did not compile with error messages from the compiler. I have not been able yet to post a comment on the if-not-true-then-false website.


This driver is available and readily built and working with Leap 15.4 as described here:

I see in the link that you posted that there is also a patched 340.108 driver:

G03 = driver v340 = legacy driver for GT8xxx/9xxx devices (via a community user)

This would allow me to use the video card currently installed (GeForce 9600 GT) without the need to replace it. However, I also found the following thread:

pointing out that there could be problems with it. One of the users reports a kernel panic after a kernel update, but I’m a bit confused which driver they are actually using. Somebody recommended filing a bug report:

Create bug report. Nvidia drivers from repo had some troubles previously.

Has anybody installed the "G03 = driver v340 " in openSUSE Leap 15.4 with kernel 5.14.21-150400.24.69 and can please confirm that it actually works, especially without causing a kernel panic?

That would be highly appreciated.


Only G04, G05 and G06 are available in the Nvidia repo. The G03 driver is a user build and may or may not work. If i look into the user OBS project, the G03 is also no longer actively maintained by this user…(as it gets harder and hard to build this package with actual kernels and the old driver 340 may contain security problems as it is no longer maintained upstream).

OK, thanks for the clarification. I had also tried the patch from the website if-not-true-then-false but it failed to compile. I have no way to tell whether the same person is the author of both the G03 driver and the if-not-true-then-false website. But this is irrelevant now. Updating the video card should allow me to use the proprietary drivers. But I read that NVIDIA is now releasing their drivers open source for newer cards, which is certainly a good idea and good news for Linux users.

… although it doesn’t solve the problem with older cards.

GeForce GT 430 support is dropped by Nvidia.
Use GPU from Maxwell (GM) family or newer.

My understanding is that the driver 390.157 is compatible with the kernel in Leap 15.4. Is there any problem using the GT 430 with 390.157 in 15.4?

For what reason to you require NVidia’s proprietary drivers?

According to Wikipedia, my GT 630 is a rebranded GT 430, so might be the same as yours. It WFM just fine with 2 displays and pure FOSS:

# inxi -SGaz --zl
  Kernel: 5.14.21-150400.24.63-default arch: x86_64 bits: 64 compiler: gcc
    v: 7.5.0 parameters: root= ipv6.disable=1 net.ifnames=0
    noresume consoleblank=0
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.2 wm: kwin_x11 vt: 7 dm:
    1: TDM 2: XDM Distro: openSUSE Leap 15.4
  Device-1: NVIDIA GF108 [GeForce GT 630] vendor: Gigabyte driver: nouveau
    v: kernel non-free: series: 390.xx+ status: legacy-active (EOL~late 2022)
    arch: Fermi code: GF1xx process: 40/28nm built: 2010-16 pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 ports: active: DVI-I-1,HDMI-A-1 empty: VGA-1
    bus-ID: 01:00.0 chip-ID: 10de:0f00 class-ID: 0300 temp: 45.0 C
  Display: x11 server: X.Org v: 1.20.3 compositor: kwin_x11 driver: X:
    loaded: modesetting unloaded: fbdev,vesa alternate: nouveau,nv,nvidia
    dri: nouveau gpu: nouveau display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3600x1200 s-dpi: 120 s-size: 762x254mm (30.00x10.00")
    s-diag: 803mm (31.62")
  Monitor-1: DVI-I-1 pos: right model: Dell P2213 serial: 
    built: 2012 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
    size: 473x296mm (18.62x11.65") diag: 558mm (22") ratio: 16:10 modes:
    max: 1680x1050 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-1 pos: primary,left model: NEC EA243WM
    serial:  built: 2011 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 519x324mm (20.43x12.76") diag: 612mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 640x480
  API: OpenGL v: 4.3 Mesa 21.2.4 renderer: NVC1 direct-render: Yes

For what reason do you require NVidia’s proprietary drivers?

openGL applications are very slow with the Nouveau driver. Have you tried for example google-earth with your GT 630 and Nouveau driver? Unless there is an alternative to either Nouveau or NVIDIA proprietary drivers?

As shown amongst the bold text in my prior thread post, nouveau has multiple FOSS driver meanings.

One of the bolded drivers in that post is neither nouveau nor nvidia, so response to your “alternative” is technically yes, the default actually, used by default when neither proprietary nor xf86-video-nouveau is installed and it is not blocked by disabled KMS.

I don’t remember if I ever installed Google Earth on any PC I own, or what it was like to use on someone else’s over 3 years ago (on a Sandy Bridge i3-2100 iGPU and Leap 15.0 or 42.3).