is KDE 4.2 rc1 broken?

After backing up the whole openSUSE 11.1 partition and waiting a few days, I attempted this last KDE 4.2 upgrade to rc1.
The resulting desktop was a bit black, despite the german beer which is yellow. However, it was possible to see very well the white mouse pointer and even move it.
I tought: “They are still more cynic as I pessimist!”
Dit samebody get it working, and how?
I mean by the openSUSE distribution.
Thanks for your patience…

It works fine

I think you need to install


Did the repo change? I’m doing a zypper up right now and dozens and dozens of packages are not found. All of them on kde factory.

4.2RC1 is in Factory now

You could try the command mv .kde4 kde4backup in your homefolder.
Then try to login again.

Hi Folks!
Thanks for your great help. I had also tried switching on Factory, the packages were different, but same result. Now I know that the repos are OK and you gave me some good suggestions: now is much easier to find what is wrong.
Thanks again

Did you check for

If you get a grey/white squared background instead of a black after you install everything, please see KDE 4.2 RC1 - Blank Desktop - openSUSE Forums for how to downgrade back.

Bugged out for me with the latest factory version, and for at least one more person as well.

I guess I just tried to get in at a bad time. I updated again and all is working. It cured the blank screen problem as noted in other thread.

I’m using 4.2 on a test machine. Is it time to move it to the main pc?

edit: this post scored me another gecko :slight_smile: