Is anybody using the latest GfxG04 nvidia drivers with the latest kernel successfully?

I’ve been trying to update my systems “tumbleweed” nvidia driver and kernel for months now and every time I try to include these in a dup the system will not boot into the gui and dumps me into a basic terminal login. The system is otherwise up to date except the kernel and drivers; this is what I’m Currently running as the last known combo to work.

rpm -qa nvidia-*; uname -a
Linux localhost.localdomain 5.17.4-1-default #1 SMP PREEMPT Wed Apr 20 07:43:03 UTC 2022 (75e9961) x86_64 x86_64 x86_64 GNU/Linux

I’d like to update the kernel and nvidia drivers to see if it fixes the issue with the darn kde taskbar freezing randomly and making me switch to another terminal and back to get it working about. It’s annoying and disruptive to say the least. Seems there’s others out there with this issue to per reddit and google searches.

If you’re using the G04 drivers with the new 6.x kernel and used zypper to install it like normal “zypper dup” how were you successful? I’ve been running tumbleweed for years now and other than having to wait a few weeks for a driver patch when a new kernel dropped it’s been a simple “zypper dup” and reboot.

I’ve been watching these url/s to see when new drivers and patches come out. It seems like the latest driver and kernel should work. I just tried it and it again dumps me into a terminal on reboot. Is there a script we can use to gather debug info encase I decide at this point to file a bug if in fact that’s what it is?


Why another thread?

Additionally, you seem to have many locks. Did you properly remove them?

Cause that post is over a month old…and I decided to frame the question differently which is why I specifically asked in this one if anybody is running the new drivers and kernel and how they achieved it as to opposed to it’s not working for me. I do see your point, I thought about updating that one but thought maybe a new one asked differently might help. And, that older post was dup/ed against that older driver posted at that time. I tried today with the new one that dropped on the 14th of this month. I only have the kernel and nvidia drivers locked and only unlock when I want to update them once I have confirmation from the links it’s reported to be patched. Historically this method has worked for me. So, what I normally do is dup the system locked…once that’s confirmed working I’ll remove all the locks and run dup again which then pulls in the new nvidia drivers and new kernel, compiles the modules, installs the new kernel and updates grub. Then I’ve always just rebooted into the new kernel. I was going to file a bug report based on the last thread but thought I’d give it some more time since the 6.x kernel is fairly new. I was hoping somebody had success with the new kernel and drivers by now. I’d really not want to go down the path of manually installing the drivers etc as I prefer to keep the system tidy using the package manager. If I do need to fill a report is there a script or documentation on what to collect?