Ipv6? Firefox fast but all the rest slow


I have a big issue which really goes on my nerves for weeks now but I can’t find a solution for myself.

The situation is this: In my openSuse11.2 system I have simply unacceptable internet perfomance which I can’t observe in Windows7 on the same machine/network.

I think it’s mostly about ipv6. I found out that Firefox runs pretty nice when I set in about:config the option “network.dns.disableIPv6=true”.

this obviously has only an effect on Firefox. So how can I achieve the same for the complete system?

I disabled ipv6 in the kernel. I verified that ifconfig shows no ipv6 information at all - but still - it must be something in the system which results into sluggish internet performance.

I’m clueless :frowning:


In Yast Network Settings, uncheck “enable IPv6”, it’ll tell you you need to reboot.

Yast Control Centre
Network Devices
Network Settings
Global Options Tab
Uncheck Enable IPv6 in 2nd block after Network Setup method

I’ve had trouble in past with IPv6 and my ISP’s network (and glibc issues), so disabling IPv4 is standard during the install, when setting up the network.

IPV6 is already disabled system wide. I have unchecked the “enable IPv6” checbkox. reboot. same thing :frowning:

Well it’s not having IPv6 enabled then is it. So what “Internet performance” is unacceptable?

If it’s DNS lookup, then perhaps running dnsmasq to cache local queries would be a nice solution. What nameservers are you using, are firewalls interfering? Is the first one very slow?

Check with “time host lwn.net <server1.foo.dns>” for example.

Do make sure you have applied all applicable updates. There’s a kernel update coming, that’s available in update/11.2-test at moment, if you have a driver issue that might help once we’ve ruled out configuration errors.

You need to be more specific or we can’t make good suggestions.