iPhone 7 plus in 42.2 Leap

Need some help here, I have a iP7+ and can’t get access to photos. In 42.1 Leap with the same phone I was able to access the photos without any problem, plug in the USB grant access on the iP7+ and there they were. Installed 42.2 and now I can’t access the photos anymore. Plugging in the phone triggers the “allow” access on the device, usb shows device plugged in, but will not mount, says “Apple iPhone 5 (PTP mode)”. I tried installing usbmuxd, but would get double mounts with it installed, I removed usbmuxd (libusbmuxd4 and libusbmuxd4-32 are already there). I visited libimobiledevice site, noticed that possibly might need “ifuse”, so installed that, still not mounting. Don’t know if it the iP7+ or suse that has the problem. was looking for a way to reset allowed devices on the iP7+ thought that might be the problem but can’t find that, don’t want to do full rest of device. Once I click on the Apple iPhone5 (PTP mode) it opens to store_feedface, about.txt and summary.txt (when I click on the .txt file get – Could not read. Reason: Directory not found) none of which contain anything. In the device notification it shows “Camera” but the mount and unmount arrow will not mount or unmount device it is in the unmounted position. Oh and each time I insert the usb cable I have to “allow” device access again, it should be remembered and this not needed.

Almost same here :

iphone 5 works here, only it takes a while to mount.
I plug the iphone 5 in the usb port while it is off and wait for a while
then turn it on put the pass code and unmount remount and I get the pictures and video to show-up.
This on Leap 42.2 and Tumbleweed.

Update, I found out how to reset phone remembered access devices, cleared that and tried, didn’t work, back to square one. Removed the usbmuxd after installing it again, again got double device notifications when it was installed along with the other libs of it. Something is not allowing the mounting of the iP7+ device in a read mode. I miss Android in some respects but then in others (updates by carrier, manufacture) I don’t.

Hmm, will try that and see. Thanks.