Invalid command 'SecRuleEngine'

I have just installed SuSE 11.1. When I try to start Apache 2 from the command line I get the following:

Starting httpd2 (prefork) Syntax error on line 2 of /etc/apache2/conf.d/mod_security2.conf:
Invalid command ‘SecRuleEngine’, perhaps misspelled or defined by a module not included in the server configuration

When I try to install it using YAST I get the following

Cannot adjust ‘Apache2’ service

I have narrowed it down to ModSecurity. I have reinstalled all the Apache 2 apps and all the required libraries and modules. No luck. Is it something I am doing? Any help and advice you can offer would be greatly appreciated.

Bucciacas :question:

Platform: OpenSUSE 11.1

I had this exact same issue. This is how I solved it.

I downloaded the latest tar of ModSecurity, unpacked the tar, read the compile and install instructions. Follow them step by step.

I then added the following to my httpd.conf file, please note that this was probably not the most elegant of solutions, but it worked.

Includes for ModSecurity2

LoadFile /usr/lib/
LoadFile /usr/lib/
LoadModule security2_module /usr/lib/apache2/
Include /etc/apache2/conf.d/mod_security2.conf

The only bug I had was that the debug and session logs for ModSecuriy failed to build. “mlogc” so I had to comment them out in the mod_security2.conf file.

Other than that, Apache2 is up and running fine.
Hope this helps!

-DJT9000 :nerd:

If anyone has a solution to the “mlogc” build issue, please post.