Internet problem - browser unable to access servers

I have been using Tumbleweed for some time and would like to upgrade to Leap 15.1. I booted from USB and selected upgrade, started process. Got to selecting partitions and was unsure if this would leave my /home partition untouched, so I aborted the upgrade. Now I am unable to access any website or my email accounts from my desktop. Wifi is still working OK.

I can login to the modem and this all seems fine. I googled to find a solution and tried to use KDE NetworkManager. I found that there were now no network connections so I managed to add one. But I still cannot use any websites or my email. I am just getting a page which says ‘Unable to reach the server’.

Tumbleweed is the “Upgrade” for Leap 15.1/15.2, not vice versa.
Leap15.1—Leap 15.2 but Tumbleweed is a rolling distribution, all packages are mostly the newest one.

Because Tumbleweed is using a newe PIM Suite, there were some changes in the configs, that can not be undone.

And adding to the above from @Sauerland. Using the Upgrade item from the main menu of an installation medium is only supported from a version to the next. Thus not backwards from Tumblweed to Leap 15.1, even jumping backwards over 15.2

What you did is downgrading, not upgrading.

When yo would have a problem as you tell with a “normal” or normal upgraded system I would point you to the folloeing basic bug searching:

You check from bottom to top:

  • Is the NIC up with an IP address?
ip addr
  • Can you connect to another system on your LAN?
ping -c1 <IP-address of your router>

(I hope you know that address)

  • Do you have a default route to the Internet?
ip route
  • Can you connect to a system on the internet?
ping -c1
  • Can you resolve host/domain names?
ping -c1

Take care. As soon a one step fails, that must be resolved first. It is useless to go to the next step before it is resolved.

So start with 1. and do not hesitate to post the output here to get help on the interpretation.

But we assume that your system is broken on maybe different points, IMHO it would be better to first see that you get a “clean” Leap 15.1, or much better a “clean” Leap 15.2.

openSUSE Tumbleweed is a rolling release providing the latest (tested) openSUSE packages so a move to openSUSE Leap 15.1 would not be an update (and there is openSUSE Leap 15.2 available already which will provide newer packages than 15.1 however still not the latest ones which Tumbleweed provides).

If you want to move from openSUSE Tumbleweed to openSUSE Leap you will have to do a fresh install no upgrade.

If you really terminated at that point then your existing system should not have been modified (i hope so at least).

Sounds to me like a DNS-related problem.

Please show the results of

> ping


> ping


> cat /etc/resolv.conf

Execute the commands in a console and paste the results (incl. the command line, the command executed and the empty command prompt following the results) here (using Code Tags).



Sorry! Henk was faster than me.

I have run the checks provided by Henk. I can’t paste the code here as I am having to do this on a tablet over WiFi. But all seems to be OK up to the last step - I can ping the IP address but not the site name - ‘Name or service not known’. So I am guessing this is a DNS problem. The last two lines of /etc/resolve.conf are:
which are OpenDNS servers which I have been using for years.


Did you set those DNS-servers manually or were they distributed by your DHCP-Server via DHCP to your machine?

Are you using wicked or NetworkManager to manage your network access?

Is the behavior the same with LAN (cable) and WiFi?


# netconfig -f

solve the problem?



The DNS servers were set manually on the modem, as far as I recall. I have been using them for a number of years and they were working fine until yesterday.


Only on the LAN. This is the only device connected by cable. All other laptops, tablets and mobiles are using WiFi with no problems.


netconfig -f update

but doesn’t seem to have made any difference.

The DNS servers were set manually on the modem, as far as I recall. I have been using them for a number of years and they were working fine until yesterday.

The last two lines of /etc/resolve.conf are:
which are OpenDNS servers which I have been using for years.

So show us:

cat /etc/resolv.conf
ls -la /etc/resolv.conf

Please use for each command a separate Code-Tag and show it with the whole input line.

I am not sure how I can copy the output here. The problem is on my desktop which is in an outdoor office with no WiFi and no way to connect with the internet so no email. I am posting here on my tablet via Wifi in the house. So I can’t just copy/paste the code. I will try to sort this out tomorrow morning.

Code as requested:

 mike@linux-g6ri:~> cat /etc/resolv.conf 
### /etc/resolv.conf file autogenerated by netconfig! 
# Before you change this file manually, consider to define the 
# static DNS configuration using the following variables in the 
# /etc/sysconfig/network/config file: 
# or disable DNS configuration updates via netconfig by setting: 
# See also the netconfig(8) manual page and other documentation. 
# Note: Manual change of this file disables netconfig too, but 
# may get lost when this file contains comments or empty lines 
# only, the netconfig settings are same with settings in this 
# file and in case of a "netconfig update -f" call. 
### Please remove (at least) this line when you modify the file! 


mike@linux-g6ri:~> ls -la /etc/resolv.conf 
lrwxrwxrwx 1 root root 30 Oct 12 13:48 /etc/resolv.conf -> /var/run/netconfig/resolv.con


mike@linux-g6ri:~> nslookup 

Non-authoritative answer: 
Address: 2a00:1450:4009:800::2003 


I am now accessing the internet using a laptop on an ethernet cable to the same switch as the desktop with no problems.
I am assuming that the above code shows the desktop to be using the OpenDNS nameservers and that these are resolving the domain names correctly.
I have downloaded the latest Tumbleweed DVD image so perhaps I should try to upgrade using this to see if this will resolve the problem? Obviously this does not solve what has happened with the existing installation but it would allow me to get back to using the computer.

As a further test of connectivity… can you download a file using wget, for example (a small, approx 60k, text file):


Should result in something similar to this:

paul@Orion-17:~/Global/Temporary> wget
--2020-10-14 14:04:21--
Resolving (, 2001:67c:2178:8::13
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: [following]
--2020-10-14 14:04:21--
Resolving (,
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 61754 (60K) [text/plain]
Saving to: ‘Changes.20201012.txt’

Changes.20201012.txt                         100%=============================================================================================>]  60.31K  --.-KB/s    in 0.04s   

2020-10-14 14:04:21 (1.58 MB/s) - ‘Changes.20201012.txt’ saved [61754/61754]


If so then take a look at your browser/mail client network settings to see if there’s anything amiss there.

Are you able to try an alternate browser/mail client?

Do you have the same problem if you create a new test user?

Also… How up to date is your existing Tumbleweed install, when was the last time you did a “zypper dup”?

Result of wget:

 mike@linux-g6ri:~> wget 
--2020-10-14 14:20:23--
Resolving ( failed: Name or service not k
wget: unable to resolve host address ‘’ 


Using Opera I get the same result - ‘This site can’t be reached’.

New test user has the same problem.

Unfortunately not very up to date. When I have tried to update I get a stream of messages that some dependancy cannot be found, and a list of possible steps to take. I can’t be sure of what will happen if I take any of these, i.e. will I compromise the installation, so I have aborted the update.

OK… Tumbleweed is a “rolling” release and as such is intended to be updated frequently, each update being performed by “zypper dup”. If your install hasn’t been updated for a while it may not be possible to succeed with a zypper dup, (even if you had network access).

It’s difficult to know exactly what you problem actually is, the aborted attempt to install (at the point you did it) shouldn’t have changed anything. When you had previously attempted to update, the dependency errors may indicate you have incompatible repositories enabled.

Your “best” course of action is perhaps likely a new install, however before going down that route you’ll need to decide if you’re going to continue with Tumbleweed, or opt for the stable “Leap” release, currently at 15.2

Either way you can choose to keep your existing home partition and any data it contains.

But… it is probably best to start with a default desktop and application settings, even more so if you opt for Leap 15.2, which is effectively a “downgrade” from Tumbleweed.

Prior to attempting a new install, rename the directories : ~/.config and ~/.local to, for example ~/.config-oldTW and ~/.local-oldTW . Those two directories will be created afresh on your new install with all default settings.

The renaming will have to be carried out from the command line, not from within a desktop environment:

Logout from the desktop, switch to a VT (ctrl-alt-F2), login as your normal user then at the command prompt use:

mv ~/.config/ ~/.config-oldTW
mv ~/.local/ ~/.local-oldTW

Unless there is a degree of urgency you may wish to wait to see what others advise… But I think in your situation I personally would go for a fresh install, and Leap may better suit your needs.

Thanks Paul, I have been thinking that a fresh install would be the best at this stage. It would mean I get back up and running with no further delay. I have to stop now anyway, so I will leave it until tomorrow and see if there are any other suggestions.

If you can query an external DNS-server then there has to be “some sort of connection” to the public network.

Please show the result of

# traceroute

Without a working network connection it will be very hard/impossible to repair your system (i.e. you might have to do an installation from scratch).



I can try traceroute tomorrow but wouldn’t hold out much hope. I’ve pretty much reached this conclusion, so am probably going to be doing a fresh install.
Thanks for your help. Regards, Mike