"Internal Error" on first boot using WSL

Good morning/afternoon/evening everyone,

I wanted to set up a Linux environment on my Windows laptop so I decided to use WSL [more info here: https://en.opensuse.org/openSUSE:WSL]. Upon downloading the .appx file from http://download.opensuse.org/repositories/Virtualization:/WSL/openSUSE_Leap_15.2/, I installed it. Then, on first launch, it said “Installing…” in a Command Prompt window, and after some time it goes to this screen:
https://imgur.com/OuwZbGxhttps://imgur.com/OuwZbGxhttps://cdn.discordapp.com/attachments/366987951734784012/737063988356972665/unknown.png

What’s causing this?

WSL is a Windows hack it may not have caught up with the newest OS.

Maybe try installing 15.1 and doing a live upgrade to 15.2

localectl talks to systemd-localed over D-Bus. So logically this could be one of

  1. something with D-Bus
  2. systemd-localed is missing
  3. systemd-localed fails to determine current locale

In any case you should do what the message says - open bug report attaching debug information. If you triage the issue and determine which of these possibilities is the real cause of error - it certainly will facilitate timely resolution.

yeah I dunno what that was, apparently 15.2 isn’t compatible with WSL, so I went to 15.1 and it works fine…just can’t get X window manager to work :cry:

Hey guys,
There shouldn’t be a problem if you know how to set things up properly.

First,
Before proceeding you need to enable WSL in the Windows Advanced Application configuration.
If you only check the box for WSL, then you’ll be running original WSL where you’re running a virtual Linux kernel shimmed to the Windows kernel. It works fine if you do this.

If you check both the box for WSL and for Hyper-V, then you’ll be running WSL2, where you’ll be running a real Linux kernel and the entire openSUSE will be running in a Hyper-V Guest.

There can be major differences in how code runs and in particular how you configure I/O like networking.

After preparing your machine by the above configuration,
The simplest way to install WSL openSUSE is to simply go to the Microsoft Store, do a search for openSUSE and install it.
Last I checked, the Microsoft Store has cleaned up multiple redundant openSUSE apps, so it’s less confusing but if you do find only something for 42.3, 15.0 or 15.1, just use it… No matter what the install is called, it will always install the latest available which should be 15.2 today.

In just a few seconds,the install should complete and you can start exploring.

TSU

I have 15.2 installed on newest builds of W10 as WSL. It does have some of the “quirks” but so far, nothing serious.

For Hyper-V, do you mean the “Windows Hypervisor Platform”? I’m not sure what you mean by Hyper-V

yeah I got past that screen by just hitting “OK”, but I had some X server errors, so I thought it was a problem with the version. guess not, then.

Regarding XServer, download and install X-Ming, and add a line


export DISPLAY=0:0

in your ~/.bashrc

Yes.
Be forewarned that if you already have some other virtualization hypervisor installed like for Virtualbox or VMware, those will conflict with Hyper-V (so don’t install it for now). VMware has been developing a special version to run on the Hyper-V hypervisor to avoid the conflict, I understand Virtualbox is supposed to be doing the same but haven’t yet seen direct evidence of something happening.

If you intend to run an XWindow environment, you’ll want to install WSL2 if possible, because openSUSE would be running in a VM, you won’t have the same kind of issues you’d have in WSL where as @SJLPHI describes, you’d have to deploy a 3rd party X server (and IIRC it will likely take more than just adding a line to your bashrc).

TSU

Just a heads up, LEAP 15.2 is incompatible with WSL2 1173916 – Install fails on Windows 2004 WSL2

I usually have Hyper-V disabled and use WSL1. I’ve been using Xming since Cygwin and has been my go-to for third party Xserver application. I do have issues with some applications but not all. Specifically, when the X is forward through SSH, the Xapplications displayed by XMing sometimes cannot be resized so that I can have access to all of the menu items. I haven’t found a perfect solution because when I have such problems, I just boot Tumbleweed or Leap 15.1.