Intel Skylake help?

I have this laptop…&skuId=4556202

I have tried multiple distros and multiple kernel versions (all the way up to 4.6 RC1) yet I still get a very annoying screen tear even after installing Nvidias Linux Drivers. I do not even care about the Nvidia card working in Linux I just want the Intel graphics to work. What can I try to get my goal of the Intel graphics working correctly. I am willing to use whatever version of Opensuse it takes and whatever kernel version it takes. Just let me know what to do guys. Thanks for any and all help.

For the record Opensuse Leap using boot parameters “idle=nomwait” and “nomodeset” will boot and let me install it but the screen tearing occurs but I can not get Opensuse Tumbleweed to boot at all

The Intel Driver needs Kernel Mode Setting, so nomodeset is not as good…

Please post:

/sbin/lspci -nnk | grep -EiA3 'vga|3d|display'

Should I do this in Leap or Tumbleweed? As I said I can not get Tumbleweed to boot at all though. Right now I do not have either installed but I am looking for advice on possible actions that I should take

That will only show your graphic cards, so you can do it with Leap.

And the Installation of the normal Nvidia Driver is no good decision in an so named “Optimus” System.

Would you prefer me to do it on a fresh install or a system in which I have tried fixes (I assume fresh install)

I also have the screen tearing issue. My output for the command is:
00:02.0 VGA compatible controller [0300]: Intel Corporation Sky Lake Integrated Graphics [8086:191e] (rev 07)
Subsystem: ASUSTeK Computer Inc. Device [1043:1cfd]
Kernel driver in use: i915
Kernel modules: i915

It’ completely random as I saw it so far. Sometimes nothing happens for hours, but sometimes it’s a complete disaster.
Perhaps it has something to do with this: ?

You have only one Graphic card, rolltide101x has maybe 2 cards.
So it is not the same issue.

In this case I’m sorry for the bad post!

I’ve opened a bug here and there is also one opened on the intel drivers bug tracker

I also have an ASUS Zenbook UX305-UA with an Intel HD 520 running Tumbleweed with Kernel 4.5.0-3-default:

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)  (0x1916)

00:02.0 VGA compatible controller: Intel Corporation Skylake Integrated Graphics (rev 07) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 1000
        Kernel driver in use: i915
        Kernel modules: i915

Mine is not entirely tearing, but sometimes, and also randomly like yours, starts to flicker and jitter the screen. This goes on for between 0.25-3 seconds, completely random it seems. The only time when it does not seem to happen at all, is when the laptop is completely idle. Not sure if it may have something to do with CPU/GPU frequency scaling. If I find something useful, I shall return with the information.

Maybe you can try adding this file:


Section "Device"
           Identifier    "Intel Graphics"
           Driver        "intel"
           Option        "TearFree"   "true"

Then, logout and login again or reboot.

Sadly it did not work. No luck so far.

Sadly it did not work. No luck so far.

So open an Tread for your Problem, this Thread has a Problem about bumblebee.

Just as an update: On my Intel only setup I haven’t seen any graphical glitches anymore, and I’ve just updated my system twice or so since my first post on it in this thread.