Intel RAID + installation/boot fails

Dear colleagues,

I’ve been trying to install a Linux system (openSuSE 10.x or 11.x or SuSE Linux Enterprise Server 11). The PC doesn’t contain any other OS (Windows was deleted and the HDs were re-formatted).

PC with Motherboard S5000XVN (Xeon E5420 @ 2.5 GHz)
Intel(R) Embedded Server RAID Technology II Version A.08.09161344I

The RAID was configured as follows:

Device present at port 0 ST3250310AS
Device present at port 1 ST3250310AS
01 Virtual drive(s) Configured

Mode RAID 1, Status Online

I used the Intel Deployment Assistant for an unassisted installation of the OS. Since there is no option for SLES 11, I used the latest available one:
SUSE* Linux* Enterprise Server 10 SP1 (x86-64)

The disk was apparently correctly formatted and partitioned:

Disk Mount Point Filesystem Size (MB)

/dev/sda1 / ext3 8192
/dev/sda2 linux-swap 2048
/dev/sda3 /home ext3 227224

drivers installed: SW/Onboard RAID v.09.32.0207.2008, ESRTII-SATA

Intel 631xESB/632xESB SATA RAID Controller

However, the installation doesn’t finish completely (CD 1 , no repositories found); here I am using SLES 11 DVD1.
I then tried to install SLES 11 from scratch; the installer suggests the following partitioning:

delete raid partition ddf1_4c53492020202020808626820000000038c10dbb00001450_part3 (221.88 GB)
create extended raid partition ddf1_4c53492020202020808626820000000038c10dbb00001450_part3 (221.88 GB)
create raid partition ddf1_4c53492020202020808626820000000038c10dbb00001450_part5 (70.60 MB) for /boot with ext3
create raid partition ddf1_4c53492020202020808626820000000038c10dbb00001450_part6 (221.81 GB) for / with ext3
use /dev/mapper/ddf1_4c53492020202020808626820000000038c10dbb00001450_part2 as swap

The installation seems to proceed fine, however, upon the first re-boot after the installation has finished, I get the following error message:

RAID set “ddf1_4c53492020202020808626820000000038c11e8200001450” was activated
Trying manual resume from /dev/disk/by-id/raid-ddf1_4c53492020202020808626820000000038c10dbb00001450-part6
resume device /dev/disk/by-id/raid-ddf1_4c53492020202020808626820000000038c10dbb00001450-part6 was not found (ignoring)
Trying manual resume from /dev/disk/by-id/raid-ddf1_4c53492020202020808626820000000038c10dbb00001450-part6
resume device /dev/disk/by-id/raid-ddf1_4c53492020202020808626820000000038c10dbb00001450-part6 was not found (ignoring)
Wainting for device /dev/disk/by-id/raid-ddf1_4c53492020202020808626820000000038c10dbb00001450-part7 to appear: …Could not find
Want me to fall back to /dev/mapper/ddf1_4c53492020202020808626820000000038c10dbb00001450-part7? (Y/n)


Waiting for device /dev/mapper/ddf1_4c53492020202020808626820000000038c10dbb00001450-part7 to appear: …not found – exiting to /bin/sh

(please note that the ID -No. in the “RAID set” line is different from the following lines)

So far, I’ve been unsuccessful in installing ANY Linux flavour on this system. SuSE products lead to the error descibed above, Ubuntu stalls at the partitioning step, Fedora exits instantly with a GRUB error (error 15) before the installation even starts.

I have the suspicion that the RAID controller or the configuration is the reason for the failed installation. Can anybody help me to solve this problem?

Thank you very much and with best regards,


IMO if this is a Linux only machine and you must use RAID is to turn off the hardware RAID and use software raid this can be set in the install.

Actually, I’ve tried switching off the RAID system. Problem is, that for some reason the DVD drive seems to be part of it (???): the array shows the two harddisks on ports 0 & 1, and the DVD drive on port 5. I wasn’t able to change this array in the config utility, which means that with the RAID switched off I can’t install any OS from DVD.



Hmmmm that is beyond me. Sounds like some really funcky hardware. And it could be a clue why Suse does not like it.