Intel Iris Xe Graphics - flickering. Video card seems installed.

Hi.
I just installed Opensuse 15.4 and all the system seems flickering, open dialogs, hovering mouse on anything, open menus.

Any one having the same problem with this GPU?

My environment:
Dell Vostro
OS: openSUSE 15.4
[FONT=monospace]Kernel: 5.14.21-150400.24.21-default[/FONT]
DE: KDE 5.90.0 / Plasma 5.24.4
CPU: [FONT=monospace]11th Gen Intel Core i5-1135G7
GPU: [FONT=monospace]Mesa Intel(R) Xe Graphics (TGL GT2)

*[/FONT][/FONT]xf86-video-intel is not installed.

[FONT=monospace][/FONT][FONT=monospace]Some outputs:
[FONT=monospace]$inxi -G
Graphics: Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo
Display: x11 server: X.Org 1.20.3 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.4

[FONT=monospace]$glxinfo | egrep “OpenGL vendor|OpenGL ren”
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) Xe Graphics (TGL GT2)
https://paste.opensuse.org/images/80429952.jpeg
[/FONT][/FONT][/FONT]https://paste.opensuse.org/images/19920719.jpeg

Some of us are anxiously awaiting the next kernel update, which is supposed to fix several Intel graphics issues. In the mean time, try appending intel_iommu=off to the linu line appearing after striking the E key at the Grub menu. I’ve not seen it myself, but mine’s not a laptop, and not running Plasma:

# set | grep MESA
# xdriinfo
Screen 0: iris
# pinxi -GSaz --vs
inxi 3.3.21-00 (2022-08-22)
System:
  Kernel: 5.14.21-150400.24.21-default arch: x86_64 bits: 64 compiler: gcc
    v: 7.5.0 parameters: BOOT_IMAGE=/boot/vmlinuz root=LABEL=<filter>
    noresume ipv6.disable=1 net.ifnames=0 mitigations=auto consoleblank=0 5
  Desktop: Trinity v: R14.0.12 tk: Qt v: 3.5.0 info: kicker wm: Twin v: 3.0
    vt: 7 dm: 1: TDM 2: XDM Distro: openSUSE Leap 15.4
Graphics:
  Device-1: Intel RocketLake-S GT1 [UHD Graphics 730] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: DP-1,HDMI-A-1,HDMI-A-2 empty: HDMI-A-3 bus-ID: 00:02.0
    chip-ID: 8086:4c8b class-ID: 0300
  Display: x11 server: X.Org v: 1.20.3 driver: X: loaded: modesetting
    unloaded: fbdev,vesa alternate: intel dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 4240x2640 s-dpi: 120 s-size: 895x557mm (35.24x21.93")
    s-diag: 1054mm (41.5")
  Monitor-1: DP-1 pos: bottom-l model: Acer K272HUL serial: <filter>
    built: 2018 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-1 pos: primary,top-left
    model: NEC EA243WM serial: <filter> built: 2011 res: 1920x1200 hz: 60
    dpi: 94 gamma: 1.2 size: 519x324mm (20.43x12.76") diag: 612mm (24.1")
    ratio: 16:10 modes: max: 1920x1200 min: 640x480
  Monitor-3: HDMI-A-2 mapped: HDMI-2 pos: bottom-r model: Dell P2213
    serial: <filter> built: 2012 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
    size: 473x296mm (18.62x11.65") diag: 558mm (22") ratio: 16:10 modes:
    max: 1680x1050 min: 720x400
  OpenGL: renderer: Mesa Intel Graphics (RKL GT1) v: 4.6 Mesa 21.2.4
    direct render: Yes
# pinxi -C
CPU:
  Info: 6-core model: 11th Gen Intel Core i5-11400 bits: 64 type: MT MCP
    cache: L2: 3 MiB
  Speed (MHz): avg: 800 min/max: 800/4400 cores: 1: 801 2: 800 3: 801
    4: 801 5: 801 6: 801 7: 801 8: 801 9: 800 10: 801 11: 801 12: 801

Thanks for replaying mrmazda.
intel_iommu=off supposed to deactivate the video card? I was able to do that by adding ‘nomodeset’.

It is strange because I saw Iris Xe support was added for linux kernel >= 5.11, mine is 5.14.

So, let’s wait for next kernel updates…

Regards,
Lucas

Nomodeset cripples X graphics performance, while intel_iommu=off effects may be undetectable.