Installing rpm from 3rd party site / gpg key

I’m trying to install the yandex-browser (not avail in OBS) by just downloading the .rpm from yandex and installing it with sudo zypper in ./yandex.rpm.

Error message returns saying missing gpg key, so I’ve downloaded the yandex gpg key, tried importing it with rpm and rpmkeys. No results.

I’ve also tried telling zypper to disregard gpg sigs a couple of different ways. Not getting anywhere that way either.

Any advice is appreciated. I’m also wondering about the long term strategy of how to keep some rpm from a 3rd party site updated. Is it totally manual, or is there some way that zypper can track it? I’m assuming manual updating is going to be necessary.

Ordinarily zypper doesn’t check keys for individual packages.
If you install the repository, then you have various gpg-key options.
Pls post the entire output of your installation.


Thanks for the response. Input / output =

sudo zypper in ./Yandex.rpm
[sudo] password for root:

Retrieving repository ‘Packman repository (openSUSE_Tumbleweed)’ metadata [done]
Building repository ‘Packman repository (openSUSE_Tumbleweed)’ cache …[done]
Loading repository data…
Reading installed packages…
Resolving package dependencies…

The following NEW package is going to be installed:

1 new package to install.
Overall download size: 62.1 MiB. Already cached: 0 B. After the operation,
additional 225.3 MiB will be used.
Continue? [y/n/…? shows all options] (y): y
Retrieving package yandex-browser-beta-
(1/1), 62.1 MiB (225.3 MiB unpacked)
Header V4 RSA/SHA1 Signature, key ID cc5fdb34: NOKEY
V4 RSA/SHA1 Signature, key ID cc5fdb34: NOKEY

yandex-browser-beta- (Plain RPM files cache): Signature verification failed [4-Signatures public key is not available]
Abort, retry, ignore? [a/r/i] (a):

it’s up to yandex to provide the public pgp key, a quick search revealed nothing
if you want to install that package your only choice is ignore
it is possible (skype and vivaldi do it) the rpm will import a valid repository which will contain the key but you can’t know that until you install it :confused:

Ignore? I completely missed that option. Went ahead and ignored. Now installed. We’ll see. Thanks for the help.