Installing printer with CUPS

I have recently installed Suse 12.2 with cups 1.5.3 . I am using a Samsung ML 2851nd printer that works well with other distros and Windows remote. I try to install it with cups as socket:// but cups will not print the test print job. This is the method I used for Ubuntu and it works. Installing with YAST is another problem. How do I need to install this printer in suse?

Assuming you can pint the printer, and have the correct printer configured, have you also checked to make sure that you’re a member of the ‘lp’ and ‘sys’ groups? (I think the latter is crucial for network printing.)

have you tried

yast > printer > print via network > connection wizard

haven’t tried it myself as I use a wireless hp printer and setting these up in Opensuse is so easy.

don’t forget to punch some holes in your firewall.

Here are the Manuals and Drivers for this Printer:
Support - Black and White Laser Printers ML-2851ND | Samsung Printers

I have found a SDB for installing Samsung printer. I downloaded the latest drivers and extracted the content with dolphin to a folder (cdroot). I went to su to run “sh ./autorun” in the konsole. The message was “file not found”. How do I finish the install of autorun?

For that command to work, you have to ‘cd’ to the directory where it resides. The clue will be looking at the location where you downloaded it to… maybe within a sub-directory.