Installing printer Kyocera FS1020-D on Suse 11.1 ?


I tried to install my Kyocera FS1020-D laser printer (connected by USB) on Suse 11.1 - but failed to by big surprise.

I tried this using yast. yast detected the printer, but then failed, because no driver could be found. All possible driver types (gutenprint, hp, …) are checked on the page in yast.
In a second try, I used the PPD file from the vendor CD. yast seemed to accept and parse the PPD, but no reaction was visible in yast. Clicking “Continue” in yast, made yast complain about missing driver (as before)
So the printer is completely unsuable with 11.1 at the moment.


  • The printer supports both PCL6 and Postscript, so I expected no problems.
  • Installation on all previous Suse versions since I own the printer, worked without any problem. (e.g. 10.3 as latest one)
  • I’m using the downloaded DVD as install medium.
  • I also tried with the additonal Suse repositories configured in yast, while being online - no change.

Any tricks to make this working ?



OpenPrinting database - Printer: Kyocera FS-1020D

so OpenPrinting, the source on linux and printing says that the Kyocera FS-1020D works perfectly on linux, and lists several drivers, from those that Kyocera make available, to gutenprint, that work well;

have you tried CUPS? … called the common unix printing system

it is run through your web browser, but only runs locally on your machine so folks are advised not to fear any security breaches; they should be none when you run CUPS;

paste http://localhost:631/ into your browser line;

try “Manage Printers”: it is six along on the menu on our version of CUPS;

see what is in there, or if there is an option to set your Kyocera as your default;

let us know how you get along;


thanks for the tip !
This did the trick. (Funnily enough I had the same idea today on my way home from work…)

There has been one quirk:
cups also only knew about the newer FS1030D by default.
But cups accepted the ppd file, I got from OpenPrinting - The Linux Foundation

With this all options seem to work.

Funnily enough yast now…

  • shows the printer with driver names for the queues configured using cups
  • is able to set/chnage options for the already set up queues
  • but still barfs at the missing driver, when I try to set up a new queue in yast

Thanks for your help !


I will update my entry about this on the HCL
(Hardware - openSUSE)

delighted to hear it all went well; the Kyocera printers seem to get very good reviews on linux; glad that with a bit of tweaking the configuration went well;

do you want to detail for other users what you did with the ppd file you downloaded from OpenPrinting;

(sounds like having used Suse since several iterations ago that you know quite a bit about linux);

for anyone less experienced coming after you, if you described what you did in CUPS, it could be very helpful for someone else

all best wishes

I already tried to do this on the HCL-page:
Hardware - openSUSE
Maybe you want to have a look, if it is clear enough

I just checked: My first Suse entry in my machine logbook refers to 7.0 in 2000.

Earlier I tried Caldera and before that I had FreeBSD (since ~ 1998) running. (In parallel with OS/2)

I have the same issue but my MFC is a Canon MP730. This has only become an issue since I tried the KDE4.1 with Plasma desktop. It worked fine when I used the KDE 3.5 desktop. Does anyone know why the Plasma 4.1 Desktop causes the issues. Also, my program start desktop icons do not automatically paste to the desktop or the Plasma panel. Also, the icons (AKA Plasmoids?) are not added to the desktop when the programs are installed as per the KDE 3.5 desktop.
If I cannot get the printer to work, I will have to revert to the tried and acceptable KDE 3.5 version.