Installing Parallels Tools

HI. I’m new to Linux and have recently installed openSUSE 11.1 on my Macbook Pro as a virtual machine under Parallels. The installation seemed to be successful. However, when trying to install Parallels Tools I got an error from the installer saying it was unable to download kernal sources and gcc. Following advice given in the Parallels website I ran the following commands:

uname -r

apt-get install linux-headers-$(input from uname -r) make gcc

I then got the following message in Terminal: “Couldn`t find package linux-headers”.

I’d welcome any advice about how to install Parallel Tools. Am I on the right track …?


You can get the kernel sources by opening YaST>Software Management.

Sources are not installed by default because most people don’t use them.

Thank you! I was able to install kernel sources in the way you suggested, but when I tried to install ‘gcc’ - also requested by the Parallels Tool installer - YaST>Software Management asked me to insert the openSUSE CD. I inserted the DVD that I have but the system could not find it - perhaps because Parallels Tools is not installed …:\

I’d be grateful for any further advice. How can I install gcc - or how can I tell YaST where to find the DVD?

Thank you!

Presumably the computer is on-line? Go into YaST > Software sources and disable the install CD from the list of repositories. It should hopefully then look on the internet instead - and GCC is there (somewhere under patterns / development I think).

It worked! Thanks for your help.