Installing OpenSuse 11.1


I have decided to install OpenSuse 11.1 on my hard disc which also contains Windows 7 beta. The installation appeared to go OK but at the end, when I removed the live CD and rebooted there was no GRUB menu and it booted straight into Windows. I had previously installed it successfully on a USB pen drive and decided to put it on my hard disc because the pen drive takes about three minutes to boot the computer.

According to Windows the hard disc now contains various partitions(?) that are related to Linux.

I tried to reinstall Suse but now, when I boot with the live CD, I no longer get a desktop but am asked to log in at a command line. Just before I get the line “Welcome to openSUSE 11.1 - Kernel 2.6.27-9-default (tty1)” there is a message saying “Master Resource Control: runlevel 5 has been skipped” I also get the message “gdn[3355]: Warning: GdnDisplay: display lasted 1.788937 seconds” five times and then it gives the “linux login:” prompt again. Entering the username details that I supplied when installing SUSE produces an error message.

I tried the “Boot from hard disc” prompt after I had started the live CD but it booted into Windows.

Is there any way of sorting this out or is it a case of re-formatting the hard disc?

I would be grateful for any help

Please ignore my question about installing OpenSuse as I have (partially) sorted out the problem. After I lowered the display resolution I was able to use the live CD to boot into OpenSuse and re-install it. Coincidence perhaps, or does the live CD only support relatively low display resolution?

Anyway, I now have 2 other problems:

When I click on “Update System”, a window opens after a while headed “Package Manager: The connection was refused” and beneath that is the following:

“repo-debug:|] Failed to cache repo (4)
repo-non-oss:|] Failed to cache repo (4)
repo-oss: |] Failed to cache repo (4)
repo-source: |] Failed to cache repo (4)
repo-update: |] Failed to cache repo (4)”

I have a working internet connection, so that isn’t why I can’t update the system (I think). Can anyone help to solve this problem, please? I had previously installed OpenSuse on a USB pen drive and seem to remember being asked for a password after I clicked on Update System; in the present case I am not asked for a password.

The other problem is that I wanted to ‘edit menu.lst’ so that I could choose between Windows or OpenSuse and when I typed "sudo’ I got an error message that the command didn’t exist. From what I understand, I need to add my user name to a ‘sudo’ list but if this is the case, where do I find such a list, what is it called and what do I put in it? I have since edited ‘menu.lst’ by doing
‘su -
gedit /boot/grub/menu.lst’

but why do I get an error message if I just type’sudo’ (without the quotes)? I thought that ‘sudo’ was a part of Linux.

I am sorry if these seem very elementary questions but I have only been trying OpenSuse since Friday last. My reason for trying it is that I do not like the new version of Windows (Windows 7) albeit a beta version and almost certainly won’t be buying it

Not sure about your sudo problem - generally, if you’re sudoing in a graphical environment, you want kdesu for kde or gksudo for gnome. So try

gksudo gedit /boot/grub/menu.lst

For example, if you’re on gnome. Maybe the sudoers file is in YaST user / group management? That’s a guess, not at my SuSE box right now, sorry :wink: That shouldn’t matter though - the first user should definitely be in the sudoers list. A puzzle.

As for the first problem, I know a lot of people have had trouble getting YaST to run initially. Try using zypper to update first;

su -
zypper up

Then see if YaST behaves.

Hi confuseling, thanks for your message. I have drawn a blank on both counts:

typing gksudo gedit /boot/grub/menu.lst gave the message ‘gksudo: command not found’

and typing

su -
zypper up

gave a lot of error messages. They began by “Error building the cache:
‘’ ‘-o’ ‘/var/cache/zypp/solv/repo.debug.solv’ ‘/var/cache/zypp/raw/repo.debug’ /usr/bin/ line 301: susetags2solv: command not found”

This was followed by other messages saying that it was disabling various other repositories because of the above error.

I really have no idea what these messages mean or what to do about them. Have you any suggestions?

There seems to be something wrong in your install. IIt looks like the installer itself has not been installed properly, since one of the commands included in the installer cannot be found.

Hi knurpht, thanks for your message. You may be interested to know that there appeared to be quite a lot missing from my Live CD installation and having read somewhere that it is better to use the DVD, I spent the afternoon (literally!) downloading it and used it to re-install OpseSuse 11.1.

It all works perfectly now.

Good stuff!

Happy SUSEing :slight_smile: