Installing on laptop (hw/sw) raid

I’ve just tried installing openSUSE 11.1 beta3 on to my shiny new rock SL8 laptop using the hardware (hw) raid (3 disks, raid 0 for performance).

I found strange effects from the install routine, firstly it detects the hw raid (but continues to see the physical disks) however after installation it panics during boot because it cannot locate the mapper details (?!?!).

I then disabled the hw raid and opted to try and use software (sw) raid during the installation.

The install failed to allow me to setup a sw raid, the add button just fails to detect usable disks/partitions., although it can see them in the partition manager.

I finally decided to boot using another distro live disk (knoppix) and manually partitioned the three disks (had to initially use fdisk to fix the partition tables on each disk) using gparted.

Once I had my three disks and there equal size partitions, I formatted where needed and tried the openSUSE installation again.

Sure enough this time the install would allow me to setup the sw raid using the new partitions that I had created.

Booting after install was also just fine.

I guess I now need to see the speed…

Actually that reminds me, has anybody noticed a few seconds pause (8 seconds or so) just after launching openSUSE from the boot screen? (it’s after the screen goes blank, no disk activity).

Anyway, now all I have to do is see what’s not working (hw) and what is… :slight_smile:

Thanks openSUSE team!