Installing Linux on Laptop with Intel Core i3 Processor

Hi I have a Compaq CQ41 216TU laptop. It has got an Intel Core i3 Processor, 4 GB DDR3 RAM, 320 HDD and Windows 7 installed. For many days, I have been trying to install Linux on to my laptop, but failed. I tried installing Ubuntu, OpenSuSe for x86_x64, but whenever I boot up my laptop using the DVD drive, it shows the boot screen of the distibution. But on entering the install mode, the screen become black, and the process doesn’t continue further, and hence no installation. It happens for every distribution. I tried with the Live CD, still the same black screen problem. I am helpless.
Can anyone help me out, in installing Linux on to my Laptop???
Thanks in advance.


You failed to mention the one thing that is probably the cause of the trouble : The Graphics device.

Use a DVD text mode install

Last week it took the installer 20 minutes to get to a working display config on a eMachines laptop. I thought it was hanging, restarted it twice, got a long phonecall, and black screen was gone…
But like Caf4926 says, the graphics device, what is it?

Its an inbuilt graphics adapter (Intel Graphics Media Accelerator HD). Could this be the problem for the black screen? If there is a problem, it could have shown some kind of errors. I am confused…

Consider defining exactly which Intel. I have 2 different Intel graphics chips, and both work perfectly.

Have you ever tried a text mode install?

Have you run the media check on any CD/DVD’s you have been using:

On the live Cd or DVD press F3 at the initial boot menu screen and select TEXT
Hit enter

You should arrive at a login:

type: root
and hit enter, no password will be requested and you will have a prompt like this:

now type: /sbin/yast2 live-installer

That should start the text mod install.

You really need to provide more detail on your graphics. There is more than one type of Intel GMA (Graphics Media Accelerator) HD.

But I note (with this as a reference):
Intel HD Graphics - ThinkWiki that you likely need a very recent Linux distribution with kernel 2.6.33 and also note that Intel Xorg driver 2.10 or newer is recommended. This means openSUSE-11.2 is too old as it has the 2.6.31 kernel and I believe only 2.9 Intel xorg driver.

You could try 11.3 M6 or wait a few months and try 11.3 GM (final released) version.

The chip type that I have is “Intel(R) Graphics Media Accelerator HD ( Core i3)”. Is this because of the unsupported Kernel???

Did you try what I suggested in post #6

Let me google that for you

Thanks for the help Vaithy. Have downloaded Fedora 13 Beta Live CD (Prerelease), and finally my laptop booted for the first time in Linux. The graphics is good. Have found that the black screen was due to the unsupported Kernel. The new Fedora 13 has got Kernel 2.6.33 and it supports Intel Core i3 Processor. Thanks again… :slight_smile:

Fabulous !! Fedora is a good distribution. I cut my teeth back in 1998 to 2001 on Red Hat (before Fedora was created) and I liked that Linux distro. I still have good things to say about Fedora / Red Hat as a “Linux” operating system.

Note openSUSE-11.3, which will be released in mid-July this year, will have the 2.6.34 kernel and it will also have the latest Intel 2.11.0 driver. So you may wish to give that a try. If you wish to just download the live CD of openSUSE 11.3 in its current under development milestone-6 form, and play with it in order to get an early look, you can find the development liveCD here:

Thanks. I will definitely give a try to the new OpenSUSE 11.3 Milestone 6, which has also got Kernel 2.6.33.

Best wishes in trying 11.3 M6. Hopefully it works better. If it does not, you could also raise a bug report on openSUSE-11.3 M6, with guidance here: Submitting Bug Reports - openSUSE and use your forum username and forum password when logging on to bugzilla.

Actually a minor point, 11.3 M4 had the 2.6.33 kernel, but as of 11.3 M5 the kernel is the 2.6.34 kernel. Hence 11.3 M6 has the 2.6.34 kernel.

Ya, will check out both. Thanks for the information.

well, have good news, i’m just starting with opensuse, and m6 is awesome, mi laptop i working atn 80%, the video graphics works, could be better, but i tried 5 distros before (fedora 13-test,ubunut 10.04, sabayon, debian, gentoo) and finally, it’s time to say goodbye to wintendo.

obviously, the graphics isn’t good, no acpi fuction (the fan works fine), good sound, no hot keys, no power control, no batery control.

The wireless works but with wicd, and to obtain the first boot, need to disable de acpi.

i’will compile a kernel, any want it?

Toshiba Satellite A505 core i3 4gb ram:|

mmm, a big bug, the kernel detect one proccesor only with one core,

Do you see that in a regular boot, or a safe settings (or failsafe) boot? Because I believe a ‘safe settings (or failsafe)’ boot has a boot code forcing only one CPU.

Did you install 11.6 M6? or is this a 11.3 M6 liveCD boot (with no install) ? If you installed, did you check your /boot/grub/menu.lst file to ensure no boot codes before “showopts” in your menu.lst that could be hidding a boot code that forces one CPU during a normal boot? (That can happen if one did a safe setting install).

mmm, I installed 11.3 m6 on hard disk, and the grub.conf is ok, i’m using the standard boot with the option acpi=off because mi laptop is toshiba and always the acpi is a big problem, if i don’t turn off the acpi, the system can’t find the OS partition (I don’t know why, i’m still working on that), i’d not install with safe settings.

I’d try to use another kernel from the factory repositories (default, rt, xen…) and there is no change.

The CPU is in optimal conditions, “wintendo 7” runs without CPU’s problem (other problems of course :slight_smile: )

maybe the intel core i3, i5 and i7 have to wait this time for use GNU/linux. What do you think?

please, excuse my english

I have a core i7 desktop, running openSUSE-11.2. It can see all 8 cores. Same when it is running from the openSUSE-11.3 M6 liveCD. It can see all 8 cores. If there is a problem here, its related to your Core i3 and maybe your graphics/chipset combination … The Core i7 on a desktop does not have such a problem.

I recommend you write a bug report and get to the bottom of this quickly. ie Raise a bug report on openSUSE-11.3 M6, with guidance here: Submitting Bug Reports - openSUSE and use your forum username and forum password when logging on to bugzilla.

Ok it is done!!!
see u latter:|