Installing Intel graphics drivers.

I’ve installed xf86-video-intel, xf86-video-fbdev, and xf86-video-vesa. After booting, acceleration still doesn’t seem to work. Is there anything else I need to do?

In Arch Linux, we’d need to run mkinitcpio -p linux to make a new initramfs. Do I need to use mkinitrd similarly? Do I need to do something in /etc/modprobe.d or xorg.conf?

There’s no openSUSE wiki page on installing intel graphics, so this will be a good chance to add it.

It should work out of the box for intel graphics… is this new or old hardware?

/sbin/lspci -nnk |grep -A3 VGA

lsmod shows i915 is loaded. How can I actualy verify that GPU acceleration works? When I try this basic Three.js demo, the frame rate is 7fps (which I think is way too slow and makes me think I don’t have proper acceleration although Chromium reports that acceleration is enabled in chrome://gpu).

The systool command shows info for i915 which makes me think the module is loaded properly (unlike what I experience in the Three.js demo):

trusktr@linux-5nok:~> systool -m i915 -av
Module = "i915"

    coresize            = "1327104"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "12"
    srcversion          = "4667C8455D5124C1B995957"
    taint               = ""
    uevent              = <store method only>

    enable_hangcheck    = "Y"

    .altinstr_replacement= "0x0000000000000000"
    .altinstructions    = "0x0000000000000000"
    .bss                = "0x0000000000000000"
    .data               = "0x0000000000000000"
    .data..read_mostly  = "0x0000000000000000"
    .data.unlikely      = "0x0000000000000000"
    .eh_frame           = "0x0000000000000000"
    .exit.text          = "0x0000000000000000"
    .fixup              = "0x0000000000000000"
    .gnu.linkonce.this_module= "0x0000000000000000"
    .init.text          = "0x0000000000000000"  = "0x0000000000000000"
    .parainstructions   = "0x0000000000000000"           = "0x0000000000000000"
    .rodata             = "0x0000000000000000"
    .rodata.str1.1      = "0x0000000000000000"
    .rodata.str1.8      = "0x0000000000000000"
    .smp_locks          = "0x0000000000000000"
    .strtab             = "0x0000000000000000"
    .symtab             = "0x0000000000000000"
    .text               = "0x0000000000000000"
    .text.unlikely      = "0x0000000000000000"
    __bug_table         = "0x0000000000000000"
    __ex_table          = "0x0000000000000000"
    __jump_table        = "0x0000000000000000"
    __kcrctab_gpl       = "0x0000000000000000"
    __ksymtab_gpl       = "0x0000000000000000"
    __ksymtab_strings   = "0x0000000000000000"
    __mcount_loc        = "0x0000000000000000"
    __param             = "0x0000000000000000"
    __tracepoints_ptrs  = "0x0000000000000000"
    __tracepoints_strings= "0x0000000000000000"
    __tracepoints       = "0x0000000000000000"
    _ftrace_events      = "0x0000000000000000"

Oops, I forgot to list the most relevant info (thanks malcomlewis).

> /sbin/lspci -nnk |grep -A3 VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:1488]
    Kernel driver in use: i915
    Kernel modules: i915

> cat /proc/cpuinfo | grep 'model name' | head -n1
model name    : Intel(R) Core(TM) i3 CPU       U 380  @ 1.33GHz

That’s the Intel i3-380UM.

So it seems that Intel graphics should be running smoothly, although they don’t seem to be.

Maybe chromium?

I just tried on my Tumbleweed test system;

 /sbin/lspci -nnk |grep -A3 VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0106] (rev 09)
    Subsystem: Toshiba America Info Systems Device [1179:fce0]
    Kernel driver in use: i915
    Kernel modules: i915

It’s a Intel CPU B960 @ 2.20GHz and I get 34FPS in firefox.

You could also try (assuming 64bit system?) my glmark2 package;

Hi Malcom, I just tried in FIrefox, and that demo runs at 6 FPS. Is the i3-380UM just that slow? It doesn’t seem like it should be that slow.

BTW, the machine is an HP TouchSmart tm-2150us.

The graphics speed is not that great…

Graphics Base Frequency     166 MHz
Graphics Max Dynamic Frequency     500 MHz

Compared to my test system;

Graphics Base Frequency     650 MHz
Graphics Max Dynamic Frequency     1.1 GHz

Does the cpu speed max out when running the demo?

Hi Malcom, good point about the CPU. The CPU isn’t maxed during the demo, so maybe it’s using GPU, and it’s just not that fast.

Here’s some glmark2 output:

$(build_prompt) glmark2 
    glmark2 2014.03
    OpenGL Information
    GL_VENDOR:     Intel Open Source Technology Center
    GL_RENDERER:   Mesa DRI Intel(R) Ironlake Mobile 
    GL_VERSION:    2.1 Mesa 11.1.2
[build] use-vbo=false: FPS: 113 FrameTime: 8.850 ms
[build] use-vbo=true: FPS: 112 FrameTime: 8.929 ms
[texture] texture-filter=nearest: FPS: 117 FrameTime: 8.547 ms
[texture] texture-filter=linear: FPS: 115 FrameTime: 8.696 ms
[texture] texture-filter=mipmap: FPS: 115 FrameTime: 8.696 ms
[shading] shading=gouraud: FPS: 88 FrameTime: 11.364 ms
[shading] shading=blinn-phong-inf: FPS: 89 FrameTime: 11.236 ms
[shading] shading=phong: FPS: 77 FrameTime: 12.987 ms
[shading] shading=cel: FPS: 76 FrameTime: 13.158 ms
[bump] bump-render=high-poly: FPS: 60 FrameTime: 16.667 ms
[bump] bump-render=normals: FPS: 124 FrameTime: 8.065 ms
[bump] bump-render=height: FPS: 114 FrameTime: 8.772 ms
[effect2d] kernel=0,1,0;1,-4,1;0,1,0;: FPS: 85 FrameTime: 11.765 ms
[effect2d] kernel=1,1,1,1,1;1,1,1,1,1;1,1,1,1,1;: FPS: 38 FrameTime: 26.316 ms
[pulsar] light=false:quads=5:texture=false: FPS: 102 FrameTime: 9.804 ms
[desktop] blur-radius=5:effect=blur:passes=1:separable=true:windows=4: FPS: 48 FrameTime: 20.833 ms
[desktop] effect=shadow:windows=4: FPS: 69 FrameTime: 14.493 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 69 FrameTime: 14.493 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=subdata: FPS: 64 FrameTime: 15.625 ms
[buffer] columns=200:interleave=true:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 69 FrameTime: 14.493 ms
[ideas] speed=duration: FPS: 89 FrameTime: 11.236 ms
[jellyfish] <default>: FPS: 61 FrameTime: 16.393 ms
[terrain] <default>: FPS: 7 FrameTime: 142.857 ms
[shadow] <default>: FPS: 62 FrameTime: 16.129 ms
[refract] <default>: FPS: 15 FrameTime: 66.667 ms
[conditionals] fragment-steps=0:vertex-steps=0: FPS: 118 FrameTime: 8.475 ms
[conditionals] fragment-steps=5:vertex-steps=0: FPS: 102 FrameTime: 9.804 ms
[conditionals] fragment-steps=0:vertex-steps=5: FPS: 118 FrameTime: 8.475 ms
[function] fragment-complexity=low:fragment-steps=5: FPS: 118 FrameTime: 8.475 ms
[function] fragment-complexity=medium:fragment-steps=5: FPS: 105 FrameTime: 9.524 ms
[loop] fragment-loop=false:fragment-steps=5:vertex-steps=5:^C

Thanks for the help!

Seems that way, ran glmark on the Tumbleweed test system and it’s about 8~9 times faster that your glmark output. Also ran glmark on my MacBook3,1 running Leap, it has an 965GM/X3100 gpu and runs twice as fast as your system, in the web test it runs at 4 FPS and almost pegs out 1 core only.

Hmmm, this is lame that these Intels from the 2010s can barely run graphics from the 1990s. I wish I knew this when I first bought this laptop in 2010. Oh well! It motivates me to get a new computer soon as I can. :smiley:

Maybe switch to SNA, rather than the default UXA may help, create a file in /etc/X11/xorg.conf.d called 20-intel.conf and add the following, reboot and see how it goes;

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree" "true"
   Option      "AccelMethod" "sna"