Installing Generic Desktop with icewm, how do I change the toolbar so I can quickly launch programs?

I tried copying the example from /etc/icewm/toolbar to /home/USER/.icewm and no luck on reboot or restarting icewm.

So far I just added one entry as a test but nothing shows up:

This is an example for IceWM’s toolbar definition file.

Place your variants in @CFGDIR@ or in $HOME/.icewm

since modifications to this file will be discarded when you

(re)install icewm.

prog “Firefox” ~/Icons/firefoxnew.png firefox

what am i doing wrong?

It should be there but without the icon probably.
icewm look for the icons in /usr/share/pixmap.
Not sure if it can lookup to your costumed icon.

I added thunar and used my customed icon folder and works.

maybe something like this.

prog “Firefox” /home/Icons/firefoxnew.png firefox

I’m doing prog “Firefox” /usr/share/icons/hicolor/48x48/apps/firefox.png firefox
and i’m not even seeing a place holder for the app. I’m using the zpaker theme.

All i see is icon for the main menu, “show desktop” icon, “windows list menu” and 1,2,3,4 for the desktop. If this toolbar is loaded i can easily do main menu>>logout>>restart icewm and it should show the toolbar?

It works here on 24X24 same directory as yours.
You have to logout then login.
Just wondering why you need the firefox, isn’t it, it is already
pre-installed as "Web browser in the toolbar only it is using a different icon.

prog “Firefox” /usr/share/icons/hicolor/48x48/apps/firefox.png firefox

works for my Leap 15.3 without problem. IceWM restart is sufficient, no need for logout . Infadel2 overloaded theme.

Can you try to run firefox from terminal ?
Can you try to add another application into toolbar ?

Reinstalled OpenSUSE 15.3 and I copied the toolbar file from /etc/icewm to /home/usr/.icewm using leafpad and added my firefox line and now it works. I must of messed up the first install or file handling because i was using Libreoffice to do the edits and I think i edited the file in /etc/icewm. Not sure if it mattered but now it works. Thanks for your help everyone. If I have anymore issues with this I will post again.